Bug 216728 - Error: Missing Dependency: gnome-python2 = 2.16.0-1.fc6 is needed by package gnome-python2-gnomevfs
Error: Missing Dependency: gnome-python2 = 2.16.0-1.fc6 is needed by package ...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
6
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
: 215791 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-21 13:33 EST by Peter Ennis
Modified: 2014-01-21 17:56 EST (History)
1 user (show)

See Also:
Fixed In Version: updates
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-04-25 14:46:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
repos (8.12 KB, text/plain)
2006-11-27 18:08 EST, Peter Ennis
no flags Details

  None (edit)
Description Peter Ennis 2006-11-21 13:33:06 EST
Description of problem: 

yum update
...

---> Package gnome-python2.i386 0:2.16.2-1.fc6 set to be updated
---> Package mesa-libGL.i386 0:6.5.1-8.fc6 set to be updated
---> Package system-config-network-tui.noarch 0:1.3.96-1.fc6 set to be updated
--> Running transaction check
--> Processing Dependency: gnome-python2 = 2.16.0-1.fc6 for package:
gnome-python2-gnomevfs
--> Processing Dependency: gnome-python2 = 2.16.0-1.fc6 for package:
gnome-python2-bonobo
--> Processing Dependency: gnome-python2-extras = 2.14.2-4.fc6 for package:
gnome-python2-libegg
--> Processing Dependency: gnome-python2 = 2.16.0-1.fc6 for package:
gnome-python2-gconf
--> Finished Dependency Resolution
Error: Missing Dependency: gnome-python2 = 2.16.0-1.fc6 is needed by package
gnome-python2-gnomevfs
Error: Missing Dependency: gnome-python2 = 2.16.0-1.fc6 is needed by package
gnome-python2-bonobo
Error: Missing Dependency: gnome-python2-extras = 2.14.2-4.fc6 is needed by
package gnome-python2-libegg
Error: Missing Dependency: gnome-python2 = 2.16.0-1.fc6 is needed by package
gnome-python2-gconf
[root@fc6 ~]# 


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Jeremy Katz 2006-11-27 17:29:21 EST
Does this still happen?  It looks like a somewhat out of sync mirror.
Comment 2 Peter Ennis 2006-11-27 18:08:52 EST
Created attachment 142244 [details]
repos
Comment 3 Peter Ennis 2006-11-27 18:15:08 EST
Default repo setup.
Same result today:

yum update

--> Processing Dependency: gnome-python2-extras = 2.14.2-4.fc6 for package:
gnome-python2-libegg
--> Processing Dependency: gnome-python2 = 2.16.0-1.fc6 for package:
gnome-python2-gconf
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
---> Downloading header for cyrus-sasl-md5 to pack into transaction set.
cyrus-sasl-md5-2.1.22-4.i 100% |=========================|  15 kB    00:00     
---> Package cyrus-sasl-md5.i386 0:2.1.22-4 set to be updated
--> Running transaction check
--> Processing Dependency: gnome-python2 = 2.16.0-1.fc6 for package:
gnome-python2-gnomevfs
--> Processing Dependency: gnome-python2 = 2.16.0-1.fc6 for package:
gnome-python2-bonobo
--> Processing Dependency: gnome-python2-extras = 2.14.2-4.fc6 for package:
gnome-python2-libegg
--> Processing Dependency: gnome-python2 = 2.16.0-1.fc6 for package:
gnome-python2-gconf
--> Finished Dependency Resolution
Error: Missing Dependency: gnome-python2 = 2.16.0-1.fc6 is needed by package
gnome-python2-gnomevfs
Error: Missing Dependency: gnome-python2 = 2.16.0-1.fc6 is needed by package
gnome-python2-bonobo
Error: Missing Dependency: gnome-python2-extras = 2.14.2-4.fc6 is needed by
package gnome-python2-libegg
Error: Missing Dependency: gnome-python2 = 2.16.0-1.fc6 is needed by package
gnome-python2-gconf
[root@fc6 ~]# unama -a
-bash: unama: command not found
[root@fc6 ~]# uname -a
Linux fc6.adaept.com 2.6.18-1.2798.fc6 #1 SMP Mon Oct 16 14:54:20 EDT 2006 i686
i686 i386 GNU/Linux
[root@fc6 ~]# date
Sun Nov 26 14:55:13 PST 2006
[root@fc6 ~]# date
Sun Nov 26 14:55:37 PST 2006
[root@fc6 ~]# date
Mon Nov 27 14:56:41 PST 2006
[root@fc6 ~]# cat /etc/yum.comf
cat: /etc/yum.comf: No such file or directory
[root@fc6 ~]# cat /etc/yum.conf
[main]
cachedir=/var/cache/yum
keepcache=0
debuglevel=2
logfile=/var/log/yum.log
pkgpolicy=newest
distroverpkg=redhat-release
tolerant=1
exactarch=1
obsoletes=1
gpgcheck=1
plugins=1
metadata_expire=1800

# PUT YOUR REPOS HERE OR IN separate files named file.repo
# in /etc/yum.repos.d
Comment 4 Peter Ennis 2006-11-30 20:40:12 EST
*** Bug 215791 has been marked as a duplicate of this bug. ***
Comment 5 Peter Ennis 2006-11-30 20:42:39 EST
Use pup to run 39 updates, exluding python.

Then run yum update:

[root@fc6 ~]# yum update
Loading "installonlyn" plugin
Setting up Update Process
Setting up repositories
Reading repository metadata in from local files
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Package gnome-python2-extras.i386 0:2.14.2-5.fc6 set to be updated
---> Package gnome-python2-canvas.i386 0:2.16.2-1.fc6 set to be updated
---> Package gnome-python2.i386 0:2.16.2-1.fc6 set to be updated
--> Running transaction check
--> Processing Dependency: gnome-python2 = 2.16.0-1.fc6 for package:
gnome-python2-gnomevfs
--> Processing Dependency: gnome-python2 = 2.16.0-1.fc6 for package:
gnome-python2-bonobo
--> Processing Dependency: gnome-python2-extras = 2.14.2-4.fc6 for package:
gnome-python2-libegg
--> Processing Dependency: gnome-python2 = 2.16.0-1.fc6 for package:
gnome-python2-gconf
--> Finished Dependency Resolution
Error: Missing Dependency: gnome-python2 = 2.16.0-1.fc6 is needed by package
gnome-python2-gnomevfs
Error: Missing Dependency: gnome-python2 = 2.16.0-1.fc6 is needed by package
gnome-python2-bonobo
Error: Missing Dependency: gnome-python2-extras = 2.14.2-4.fc6 is needed by
package gnome-python2-libegg
Error: Missing Dependency: gnome-python2 = 2.16.0-1.fc6 is needed by package
gnome-python2-gconf
[root@fc6 ~]# date
Thu Nov 30 17:41:02 PST 2006
[root@fc6 ~]# 
Comment 6 Peter Ennis 2006-12-04 19:46:10 EST
Still exists. Added livna repository:

yum update

[root@fc6 ~]# yum update
Loading "installonlyn" plugin
Setting up Update Process
Setting up repositories
livna                     100% |=========================| 1.1 kB    00:00     
core                      100% |=========================| 1.1 kB    00:00     
updates                   100% |=========================| 1.2 kB    00:00     
extras                    100% |=========================| 1.1 kB    00:00     
Reading repository metadata in from local files
primary.xml.gz            100% |=========================|  96 kB    00:00     
################################################## 268/268
primary.xml.gz            100% |=========================| 286 kB    00:01     
################################################## 980/980
primary.xml.gz            100% |=========================| 1.5 MB    00:02     
################################################## 4778/4778
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Downloading header for ypbind to pack into transaction set.
ypbind-1.19-6.fc6.i386.rp 100% |=========================| 9.7 kB    00:00     

...

freetype-devel-2.2.1-16.f 100% |=========================|  20 kB    00:00     
---> Package freetype-devel.i386 0:2.2.1-16.fc6 set to be updated
---> Package gnome-python2.i386 0:2.16.2-1.fc6 set to be updated
---> Downloading header for policycoreutils to pack into transaction set.
policycoreutils-1.33.5-4. 100% |=========================|  64 kB    00:01     
---> Package policycoreutils.i386 0:1.33.5-4.fc6 set to be updated
--> Running transaction check
--> Processing Dependency: gnome-python2 = 2.16.0-1.fc6 for package:
gnome-python2-gnomevfs
--> Processing Dependency: gnome-python2 = 2.16.0-1.fc6 for package:
gnome-python2-bonobo
--> Processing Dependency: gnome-python2-extras = 2.14.2-4.fc6 for package:
gnome-python2-libegg
--> Processing Dependency: gnome-python2 = 2.16.0-1.fc6 for package:
gnome-python2-gconf
--> Finished Dependency Resolution
Error: Missing Dependency: gnome-python2 = 2.16.0-1.fc6 is needed by package
gnome-python2-gnomevfs
Error: Missing Dependency: gnome-python2 = 2.16.0-1.fc6 is needed by package
gnome-python2-bonobo
Error: Missing Dependency: gnome-python2-extras = 2.14.2-4.fc6 is needed by
package gnome-python2-libegg
Error: Missing Dependency: gnome-python2 = 2.16.0-1.fc6 is needed by package
gnome-python2-gconf
[root@fc6 ~]# date
Mon Dec  4 16:42:13 PST 2006
[root@fc6 ~]# 

Comment 7 Peter Ennis 2006-12-07 13:49:27 EST
Ran pup by excluding python updates. Then run yum update
and it complains about the process lock, so kill
this and run yum update still shows the dependency error.
It does not appear to be affecting the machine in
any other way that I notice.

[root@fc6 ~]# yum update
Loading "installonlyn" plugin
Existing lock /var/run/yum.pid: another copy is running. Aborting.
[root@fc6 ~]# ps ax | grep yum
 1776 ?        S      5:06 /usr/bin/python /usr/sbin/yum-updatesd
12612 pts/0    S+     0:00 grep yum
[root@fc6 ~]# sudo kill -9 1776
[root@fc6 ~]# sudo ps ax | grep yum
12619 pts/0    R+     0:00 grep yum
[root@fc6 ~]# yum update
Loading "installonlyn" plugin
Setting up Update Process
Setting up repositories
Reading repository metadata in from local files
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Package gnome-python2-extras.i386 0:2.14.2-5.fc6 set to be updated
---> Package gnome-python2-canvas.i386 0:2.16.2-1.fc6 set to be updated
---> Package gnome-python2.i386 0:2.16.2-1.fc6 set to be updated
--> Running transaction check
--> Processing Dependency: gnome-python2 = 2.16.0-1.fc6 for package:
gnome-python2-gnomevfs
--> Processing Dependency: gnome-python2 = 2.16.0-1.fc6 for package:
gnome-python2-bonobo
--> Processing Dependency: gnome-python2-extras = 2.14.2-4.fc6 for package:
gnome-python2-libegg
--> Processing Dependency: gnome-python2 = 2.16.0-1.fc6 for package:
gnome-python2-gconf
--> Finished Dependency Resolution
Error: Missing Dependency: gnome-python2 = 2.16.0-1.fc6 is needed by package
gnome-python2-gnomevfs
Error: Missing Dependency: gnome-python2 = 2.16.0-1.fc6 is needed by package
gnome-python2-bonobo
Error: Missing Dependency: gnome-python2-extras = 2.14.2-4.fc6 is needed by
package gnome-python2-libegg
Error: Missing Dependency: gnome-python2 = 2.16.0-1.fc6 is needed by package
gnome-python2-gconf
[root@fc6 ~]# 
[root@fc6 ~]# date
Thu Dec  7 10:45:57 PST 2006
[root@fc6 ~]# 
Comment 8 Peter Ennis 2006-12-14 14:06:29 EST
System running OK. Still use pup to do all other updates while skipping
the python2 related ones.

[root@fc6 ~]# yum update
Loading "installonlyn" plugin
Setting up Update Process
Setting up repositories
Reading repository metadata in from local files
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Package gnome-python2-extras.i386 0:2.14.2-5.fc6 set to be updated
---> Package gnome-python2-canvas.i386 0:2.16.2-1.fc6 set to be updated
---> Package gnome-python2.i386 0:2.16.2-1.fc6 set to be updated
--> Running transaction check
--> Processing Dependency: gnome-python2 = 2.16.0-1.fc6 for package:
gnome-python2-gnomevfs
--> Processing Dependency: gnome-python2 = 2.16.0-1.fc6 for package:
gnome-python2-bonobo
--> Processing Dependency: gnome-python2-extras = 2.14.2-4.fc6 for package:
gnome-python2-libegg
--> Processing Dependency: gnome-python2 = 2.16.0-1.fc6 for package:
gnome-python2-gconf
--> Finished Dependency Resolution
Error: Missing Dependency: gnome-python2 = 2.16.0-1.fc6 is needed by package
gnome-python2-gnomevfs
Error: Missing Dependency: gnome-python2 = 2.16.0-1.fc6 is needed by package
gnome-python2-bonobo
Error: Missing Dependency: gnome-python2-extras = 2.14.2-4.fc6 is needed by
package gnome-python2-libegg
Error: Missing Dependency: gnome-python2 = 2.16.0-1.fc6 is needed by package
gnome-python2-gconf
[root@fc6 ~]# date
Thu Dec 14 11:01:40 PST 2006
[root@fc6 ~]# 

Comment 9 Stephen Davies 2006-12-18 04:24:06 EST
It seems that there is a general dependancy problem with Python that Yum can't
resolve.
On a fresh FC6 system a yum update fails with one Python dependancy problem.
After doing a yum update to exclude the errant package both pup and yum still
fails with a dependancy problem

[root@Tiger650]# yum update
Loading "installonlyn" plugin
Setting up Update Process
Setting up repositories
Reading repository metadata in from local files
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Package python-devel.i386 0:2.4.4-1.fc6 set to be updated
--> Running transaction check
--> Processing Conflict: python-devel conflicts python < 2.4.4-1.fc6
--> Finished Dependency Resolution
Error: python-devel conflicts with python < 2.4.4-1.fc6

Here are the Yum & Python packages currently installed.
[root@Tiger650] # rpm -qa | grep yum
yum-updatesd-3.0.1-2.fc6
yum-3.0-6
yum-3.0.1-2.fc6
yum-metadata-parser-1.0-8.fc6

[root@Tiger650] # # rpm -qa | grep python
python-urlgrabber-2.9.9-2
gnome-python2-libegg-2.14.2-5.fc6
audit-libs-python-1.2.8-1.fc6
gnome-python2-desktop-2.16.0-1.fc6
python-2.4.4-1.fc6
libxml2-python-2.6.27-1.FC6
gnome-python2-canvas-2.16.2-1.fc6
rpm-python-4.4.2-32
python-elementtree-1.2.6-5
libselinux-python-1.30.29-2
notify-python-0.1.0-3.fc6
libxslt-python-1.1.17-1.1
gnome-python2-applet-2.16.0-1.fc6
audit-libs-python-1.3-2.fc6
gnome-python2-gconf-2.16.2-1.fc6
gnome-python2-2.16.2-1.fc6
dbus-python-0.70-6
python-sqlite-1.1.7-1.2.1
python-numeric-23.7-2.2.2
gnome-python2-gnomeprint-2.16.0-1.fc6
gnome-python2-gnomevfs-2.16.2-1.fc6
libxml2-python-2.6.26-2.1.1
gnome-python2-gtksourceview-2.16.0-1.fc6
libselinux-python-1.33.2-3.fc6
gnome-python2-bonobo-2.16.2-1.fc6
python-2.4.3-18.fc6
python-ldap-2.2.0-2.1
python-devel-2.4.3-18.fc6
libxslt-python-1.1.18-1.FC6
gnome-python2-extras-2.14.2-5.fc6
#
 
Comment 10 Seth Vidal 2006-12-18 11:13:19 EST
Comment #9: you have two versions of python installed.

remove the older one: python-2.4.3-18.fc6


see if it gets better
Comment 11 Scott 2006-12-27 18:51:27 EST
Hello,

I had a similar error when trying to download the "Updated gnome-python2
packages available", which was listed in the Package Updater. This was the only
update I was trying to download. I had already downloaded and installed every
update before this one, which was after a fresh install. 

  Error resolving dependencies

  Unable to resolve dependencies for some packages selected for installation.  

  Missing Dependency: gnome-python2 = 2.16.0-1.fc6 is needed by package        
                
  gnome-python2-gconf

Thanks
Comment 12 Peter Ennis 2007-01-09 15:37:58 EST
Looks like it is fixed in this update.
Pup worked.
Yum results below.

Thanks.

[Philip@fc6 ~]$ uname -a
Linux fc6.adaept.com 2.6.18-1.2869.fc6 #1 SMP Wed Dec 20 14:51:46 EST 2006 i686
i686 i386 GNU/Linux
[Philip@fc6 ~]$ su -
Password: 
[root@fc6 ~]# yum update
Loading "installonlyn" plugin
Setting up Update Process
Setting up repositories
Reading repository metadata in from local files
No Packages marked for Update/Obsoletion
[root@fc6 ~]# date
Tue Jan  9 12:31:04 PST 2007
[root@fc6 ~]# 

Note You need to log in before you can comment on or make changes to this bug.