Bug 216739 - ypbind startup scripts needs better quoting
ypbind startup scripts needs better quoting
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: ypbind (Show other bugs)
6
All Linux
low Severity medium
: ---
: ---
Assigned To: Steve Dickson
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-21 14:24 EST by Paul Wouters
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version: ypbind-1.19-7.fc
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-26 10:59:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Paul Wouters 2006-11-21 14:24:24 EST
Description of problem:


Version-Release number of selected component (if applicable): 1.19

due to xenguest-install being broken (hangs in installer), I used the
old setup us yum with a base install in /mnt. I know this is not the
"normal" way of installing. One of the artifacts is that /etc/sysconfig/network
did not contain NETWORKING=  this fails in ypbind due to bad quoting:

 /etc/init.d/ypbind: line 28: [: =: unary operator expected


Additional info:

Change:

[ ${NETWORKING} = "no" ] && exit 0

to:

[ "${NETWORKING}" = "no" ] && exit 0
Comment 1 Steve Dickson 2007-07-26 10:59:05 EDT
Fixed in  ypbind-1.19-7.fc

Note You need to log in before you can comment on or make changes to this bug.