Bug 216742 - Feature request: Automatically exclude packages when dependencies cannot be met
Feature request: Automatically exclude packages when dependencies cannot be met
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-21 14:44 EST by Karl Lattimer
Modified: 2014-01-21 17:56 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-27 17:29:49 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Karl Lattimer 2006-11-21 14:44:23 EST
Just running pup now and I noticed something that was sort of missing in a way. 

When yum is unable to find files to resolve dependencies it could exclude them
and continue to attempt to find a dependency solution. There have been many
times in the past that I have had packages on certain repositories conflicting
or not updating in line with core and extras and the upshot is that they break
the update process. It seems logical to me that there should be a way to exclude
packages where dependency resolution cannot be met during the update and
continue possibly stating that those packages won't be updated because a
dependency is failing. 

Eventually those packages should get updated as the repositories come back into
alignment. 

For instance, in my most recent update openoffice and wine required an
older/newer version of libxslt than my system or was available had going back to
the update selection and excluding openoffice and wine from the update process
then allowed me to proceed. Surely there must be a way of doing this automatically.
Comment 1 Jeremy Katz 2006-11-27 17:29:49 EST
There's a plugin to provide this functionality.  In general, the right behavior
is that the repository shouldn't be broken.

Note You need to log in before you can comment on or make changes to this bug.