Bug 216760 - Mount with context or fscontext option fails
Summary: Mount with context or fscontext option fails
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: util-linux
Version: 6
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Karel Zak
QA Contact: Ben Levenson
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-11-21 21:15 UTC by Bojan Smojver
Modified: 2007-11-30 22:11 UTC (History)
0 users

(edit)
Clone Of:
(edit)
Last Closed: 2006-11-22 00:02:27 UTC


Attachments (Terms of Use)

Description Bojan Smojver 2006-11-21 21:15:55 UTC
Description of problem:
A command like this:

----------------------------------------------
mount -vv -t iso9660 -o loop,ro,fscontext=system_u:object_r:public_content_t:s0
/var/distro/FC-6-i386-disc1.iso /var/distro/mnt/1
----------------------------------------------

Fails with:

----------------------------------------------
mount: translated fscontext 'system_u:object_r:public_content_t:s0' to
'system_u:object_r:public_content_t:s0'
mount: going to use the loop device /dev/loop0
set_loop(/dev/loop0,/var/distro/FC-6-i386-disc1.iso,0): success
mount: setup loop device successfully
del_loop(/dev/loop0): success
mount: wrong fs type, bad option, bad superblock on /dev/loop0,
       missing codepage or other error
       In some cases useful info is found in syslog - try
       dmesg | tail  or so
----------------------------------------------

The same used to work just a week ago or so. Since then, there has been an
update to selinux-policy, but I'm not sure if that's somehow related. Anyway,
the version of the policy is 2.4.3-10.fc6.

Version-Release number of selected component (if applicable):
2.13-0.45.fc6

How reproducible:
Always.


Steps to Reproduce:
1. Attempt to mount an ISO filesystem while with fscontext or context option.

  
Actual results:
Mount fails.

Expected results:
Should work.

Additional info:
This is a mount done by hand. SELinux is running in targeted mode.

Comment 1 Bojan Smojver 2006-11-21 22:19:15 UTC
Reverting back to util-linux-2.13-0.44.fc6 fixes the problem. So, it must be
something in the new version of this package.

Comment 2 Karel Zak 2006-11-21 23:46:00 UTC
Hmm... you're right. The kernel in FC6 doesn't support context options that
contain commas :-(. I'll temporary disable this feature in util-linux. Thanks!

Comment 3 Bojan Smojver 2006-11-22 02:03:21 UTC
So, this will show up in FC6 updates-testing?

Comment 4 Karel Zak 2006-11-22 09:38:32 UTC
This will show up in FC6 updates (final updates, no testing).

Comment 5 Fedora Update System 2006-11-22 16:21:47 UTC
util-linux-2.13-0.45.1.fc6 has been pushed for fc6, which should resolve this issue.  If these problems are still present in this version, then please make note of it in this bug report.

Comment 6 Bojan Smojver 2006-11-22 19:40:51 UTC
Thanks. The new version works fine.


Note You need to log in before you can comment on or make changes to this bug.