Bug 216803 - yumex shut down on start up with an unhandled exception error
yumex shut down on start up with an unhandled exception error
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: yumex (Show other bugs)
6
x86_64 Linux
medium Severity high
: ---
: ---
Assigned To: Tim Lauridsen
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-21 20:10 EST by Glenn Sullivan
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-01-14 03:23:58 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
my copy of this file (45.52 KB, text/x-python)
2006-11-27 13:04 EST, Glenn Sullivan
no flags Details
The Exception (830 bytes, text/plain)
2007-01-13 15:08 EST, Peter Sergey Panov
no flags Details

  None (edit)
Description Glenn Sullivan 2006-11-21 20:10:01 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.8.0.8) Gecko/20061107 Fedora/1.5.0.8-1.fc6 Firefox/1.5.0.8

Description of problem:
The program crashes at startup regardless how I start it

Version-Release number of selected component (if applicable):
yumex-1.2.0-1.0.fc6

How reproducible:
Always


Steps to Reproduce:
1.I can start Yumex from a terminal by entering Yumex or click Yumex from from the system tools menu.
2.
3.

Actual Results:
unhandled exception error everytime

Expected Results:
I would like to be able to add or delete software on my system by using Yumex

Additional info:
Kernel-2.6.18-1.2849.fc6  x86_64

omponent: yumex
Version: 1.1.7
Summary: TBa9f4ab4f locale.py:381:setlocale:Error: unsupported locale setting

Traceback (most recent call last):
  File "/usr/share/yumex/yumexmain.py", line 1102, in ?
    mainApp = YumexMainApplication()
  File "/usr/share/yumex/yumexmain.py", line 499, in __init__
    locale.setlocale( locale.LC_ALL, "en_US" )
  File "/usr/lib64/python2.4/locale.py", line 381, in setlocale
    return _setlocale(category, locale)
Error: unsupported locale setting

Local variables in innermost frame:
locale: en_US
category: 6
Comment 1 Tim Lauridsen 2006-11-22 02:43:49 EST
I look like some kind of problem with the regional settings.
try:
echo $LANG
ls /usr/share/locale

and let me know what it shows.
Comment 2 Glenn Sullivan 2006-11-22 11:22:45 EST
This is the output from echo $LANG
en_US.UTF-8
[root@localhost glenngds]# ls /usr/share/locale
C                ceb          es_UY  ilo    map      pap      sux
aa               cel          es_VE  inc    mas      pau      sv
ab               ch           et     ine    mdf      peo      sv_SE
ace              chb          et_EE  inh    mdr      phi      sw
ach              chg          eu     io     men      phn      syr
ada              chk          eu_ES  ira    mg       pi       ta
ady              chm          ewo    iro    mga      pl       tai
ae               chn          fa     is     mh       pl_PL    te
af               cho          fa_IR  it     mi       pon      tem
af_ZA            chp          fan    it_CH  mic      pra      ter
afa              chr          fat    it_IT  min      pro      tet
afh              chy          ff     iu     mis      ps       tg
ain              cmc          fi     ja     mk       pt       th
ak               co           fil    ja_JP  mkh      pt_BR    ti
akk              cop          fiu    jbo    ml       pt_PT    tig
ale              cpe          fj     jpr    mn       qu       tiv
alg              cpf          fo     jrb    mnc      raj      tk
all_languages    cpp          fon    jv     mni      rap      tkl
alt              cr           fr     ka     mno      rar      tl
am               crh          fr_BE  kaa    mo       rm       tlh
am_ET            crp          fr_CA  kab    moh      rn       tli
an               cs           fr_CH  kac    mos      ro       tmh
ang              cs_CZ        fr_FR  kam    mr       roa      tn
anp              csb          frm    kar    ms       rom      to
apa              cu           fro    kaw    mt       ru       tog
ar               cus          frr    kbd    mul      ru_RU    tpi
arc              cv           frs    kg     mun      rup      tr
arn              cy           fur    kha    mus      rw       ts
arp              da           fy     khi    mwl      sa       tsi
art              dak          ga     kho    mwr      sad      tt
arw              dar          gaa    ki     my       sah      tum
as               day          gay    kj     my_MM    sai      tup
ast              de           gba    kk     myn      sal      tut
ast_ES           de_AT        gd     kl     myv      sam      tvl
ath              de_CH        gem    km     na       sas      tw
aus              de_DE        gez    kmb    nah      sat      ty
av               del          gil    kn     nai      sc       tyv
awa              den          gl     ko     nap      scn      ua
ay               dgr          gmh    ko_KR  nb       sco      udm
az               din          gn     kok    nb_NO    sd       ug
az_IR            doi          goh    kos    nd       se       uga
ba               dra          gon    kpe    nds      sel      uk
bad              dsb          gor    kr     nds@NFE  sem      uk_UA
bai              dua          gos    krc    ne       sg       umb
bal              dum          got    krl    new      sga      und
ban              dv           gr     kro    ng       sgn      ur
bas              dyu          grb    kru    nia      shn      uz
bat              dz           grc    ks     nic      si       uz@Latn
be               ee           gsw    ku     niu      sid      vai
bej              efi          gu     kum    nl       sio      ve
bem              egy          gv     kut    nl_BE    sit      vi
ber              eka          gwi    kv     nl_NL    sk       vo
bg               el           ha     kw     nn       sl       vot
bh               el_GR        hai    ky     no       sl_SI    wa
bho              elx          haw    l10n   nog      sla      wak
bi               en           he     la     non      sm       wal
bik              en@boldquot  he_IL  lad    nqo      sma      war
bin              en@quot      hi     lah    nr       smi      was
bla              en_AU        hil    lam    nso      smj      wen
bm               en_CA        him    lb     nub      smn      wo
bn               en_GB        hit    lez    nv       sms      xal
bn_IN            en_US        hmn    lg     nwc      sn       xh
bnt              enm          ho     li     ny       snk      yao
bo               eo           hr     ln     nym      so       yap
br               es           hr_HR  lo     nyn      sog      yi
bra              es_AR        hsb    lol    nyo      son      yo
bs               es_CL        ht     loz    nzi      sp       ypk
btk              es_CO        hu     lt     oc       sq       za
bua              es_CR        hu_HU  lu     oj       sq_AL    zap
bug              es_DO        hup    lua    om       sr       zen
byn              es_EC        hy     lui    or       sr@Latn  zh
ca               es_ES        hz     lun    os       sr@ije   zh_CN
ca@valencia      es_GT        ia     luo    osa      srn      zh_CN.GB2312
ca_ES            es_HN        iba    lus    ota      srr      zh_HK
ca_ES@valencian  es_MX        id     lv     oto      ss       zh_TW
cad              es_NI        ie     mad    pa       ssa      zh_TW.Big5
cai              es_PA        ig     mag    paa      st       znd
car              es_PE        ii     mai    pag      su       zu
cau              es_PR        ijo    mak    pal      suk      zun
ce               es_SV        ik     man    pam      sus
Comment 3 Glenn Sullivan 2006-11-25 18:44:52 EST
I do not understand how my regional settings could have gotten messed up.  This
is a fresh install--reformatted hard drive and so on.  I correctly answered all
questions as to location during install.  The installer must have created this
problem.  How do I go about correcting this problem with my regional settings? 
Anyway I do not believe there could be a problem with regional settings because
I am typing in English with a US keyboard with the very computer that you say
has its regional settings messed up!!
Comment 4 Tim Lauridsen 2006-11-27 02:58:40 EST
The the command there is causing the traceback, is python trying to set the 
local to 'en_US', the error message is 'unsupported locale setting'.
I am also running en_US as LANG, but i cant reproduce the error.

maybe you can try editing /usr/share/yumex/yumexmain.py (Line 499)
and change 

  locale.setlocale( locale.LC_ALL, "en_US" )

to

  locale.setlocale( locale.LC_ALL, "en_US.UTF-8" )

To see if the 'UTF-8' part make any changes.

Comment 5 Glenn Sullivan 2006-11-27 12:28:47 EST
I made changes as you suggested or I hope I did.  The line you pointed out was
not at line 499, but around line 510.  I still get the unhandled exception error
now the trace back has changed and is as follows:

Component: yumex
Version: 1.2.0
Summary: TBa9f4ab4f locale.py:381:setlocale:Error: unsupported locale setting

Traceback (most recent call last):
  File "/usr/share/yumex/yumexmain.py", line 1106, in ?
    mainApp = YumexMainApplication()
  File "/usr/share/yumex/yumexmain.py", line 503, in __init__
    locale.setlocale( locale.LC_ALL, "en_US.UTF-8" )
  File "/usr/lib64/python2.4/locale.py", line 381, in setlocale
    return _setlocale(category, locale)
Error: unsupported locale setting

Local variables in innermost frame:
locale: en_US
category: 6
Comment 6 Glenn Sullivan 2006-11-27 13:04:30 EST
Created attachment 142194 [details]
my copy of this file
Comment 7 Peter Sergey Panov 2007-01-13 15:08:27 EST
Created attachment 145534 [details]
The Exception

I got this error message after installing a number of packages. It occurred
immediately upon conclusion of installation as well as when I attempted to
start yumex up again.
Comment 8 Peter Sergey Panov 2007-01-13 15:37:41 EST
(In reply to comment #7)
> Created an attachment (id=145534) [edit]
> The Exception
> 
> I got this error message after installing a number of packages. It occurred
> immediately upon conclusion of installation as well as when I attempted to
> start yumex up again.

The issue disappeared after a reboot. My apologies for wasting your time.

Note You need to log in before you can comment on or make changes to this bug.