Bug 216818 - Rhythmbox plays stream for a second then stops.
Rhythmbox plays stream for a second then stops.
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: gstreamer (Show other bugs)
6
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Adam Jackson
:
: 218316 224212 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-21 23:26 EST by PsychoTrauma
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version: 0.10.11-1.fc6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-04-11 09:35:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
output from rhythmbox --debug (7.94 KB, text/plain)
2006-11-21 23:26 EST, PsychoTrauma
no flags Details

  None (edit)
Description PsychoTrauma 2006-11-21 23:26:25 EST
Rhythmbox buffers and starts to play the ogg stream then it stops after just a
few seconds.

The ogg stream is located at http://death.fm/Ogg-hi.m3u

I am using version 0.9.5 of rhythmbox and my fedora core 6 install is all up to
date. I do not have any 3rd party software installed only just what comes by
default. I opened a terminal and did rhythmbox --debug and I am including the
output.

Thank you for you time and effort, James
Comment 1 PsychoTrauma 2006-11-21 23:26:25 EST
Created attachment 141867 [details]
output from rhythmbox --debug
Comment 2 PsychoTrauma 2006-11-22 22:50:12 EST
I tested the same stream with other players that use the gstreamer backend and
got the same results. This leads me to believe the issue is not with rhythmbox
but with gstreamer.
Comment 3 Matěj Cepl 2007-01-11 10:12:09 EST
Can reproduce on RHEL5b2 (gstreamer 0.10.10). Kind of -- apparently M3U playlist
format is too complicated for gstreamer so gst-launch playbin gives up with message

** Message: don't know how to handle text/uri-list
ERROR: from element /playbin0: You do not have a decoder installed to handle
this file. You might need to install the necessary plugins.
Additional debug info:

(I really cannot believe that it doesn't understand M3U lists).

However, when I try the URL of the real stream
(http://ic.death.fm:80/dfm64k.ogg) gst-launch has no problem playing it (I have
problem listening to it, but that's not software issue, I suppose).
Comment 4 Matěj Cepl 2007-01-11 10:16:57 EST
Oops! gst-launch cannot play m3u playlists, but rhythmbox can and gstreamer can
play it as well. Just tested. Shouldn't it be WORKSFORME?
Comment 5 Matěj Cepl 2007-01-11 10:39:04 EST
Using rhythmbox-0.9.7-4 and gstreamer-plugins-base-0.10.11-0.gst.1.6 (not in FC6
yet)
Comment 6 Bastien Nocera 2007-02-02 04:44:13 EST
*** Bug 218316 has been marked as a duplicate of this bug. ***
Comment 7 Bastien Nocera 2007-02-02 04:44:54 EST
*** Bug 224212 has been marked as a duplicate of this bug. ***
Comment 8 Bastien Nocera 2007-04-11 09:35:07 EDT
This should have been fixed in gstreamer-plugins-base 0.10.11-1.fc6
Comment 9 Steve Fox 2007-04-11 16:12:46 EDT
For the record, this update did not fix my bug (Bug 224212), but I will report
to the Rhythmbox Bugzilla since it's apparently an upstream issue. Thanks.
Comment 10 Steve Fox 2007-04-11 16:22:27 EDT
Actually, I mis-read which package that fix is in and I do not yet have the
updated one. Please pardon the noise.
Comment 11 Steve Fox 2007-05-10 22:57:11 EDT
gstreamer-plugins-base-0.10.11-1.fc6 has now made it out to the mirrors, but I
still cannot play the station I reported in #224212. If it helps at all, I can
play the station with my Rawhide machine.

Note You need to log in before you can comment on or make changes to this bug.