Bug 216821 - freezes with certain profiles
freezes with certain profiles
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: sound-juicer (Show other bugs)
5.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Alexander Larsson
: Desktop
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-21 23:40 EST by Matthias Clasen
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version: 5.0.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-01-08 04:00:14 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matthias Clasen 2006-11-21 23:40:44 EST
This bug was originally reported here:
http://bugzilla.gnome.org/show_bug.cgi?id=361151
and the fix is available in 2.16.2
Comment 1 Matthias Clasen 2006-11-23 00:12:00 EST
fixed in sound-juicer-2.16.0-3.el5
Comment 3 RHEL Product and Program Management 2006-11-27 21:36:32 EST
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 4 Nicole Dai 2007-01-07 21:58:50 EST
Tested the bug with the following environment and case:
Env:
RHEL5-Client-20061226.nightly
# rpm -qa | grep gstreamer
gstreamer-plugins-fluendo-video-0.10-7.el5
gstreamer-tools-0.10.9-3.el5
gstreamer-plugins-base-0.10.9-6.el5
gstreamer-plugins-good-0.10.4-2.el5
gstreamer-plugins-ugly-0.10.5-1.fc6
gstreamer-plugins-fluendo-windowsmedia-0.10-7.el5
gstreamer-plugins-fluendo-mp3-0.10-7.el5
gstreamer-0.10.9-3.el5

sound-juicer-2.16.0-3.el5

1. Insert an Audio CD.
2. Applications -> Sound & Video -> SoundJuicer CD Extractor.
(The CD wld be mounted, and Tracks would appear.)
3. Edit -> Preferences -> Format -> OutputFormat.
4. Select the required Output format and Edit Profiles.
5. Click on Edit Profiles, click New and name the profile MP3. 
6. Select the MP3 profile and click the Edit button. Set GStreamer Pipeline to
"audio/x-raw-int,rate=44100,channels=2 ! lame name=enc vbr=0 bitrate=196 !
id3v2mux".
7. Tick "Active?" option, click OK.
8. Choose the Profile as Output Format.
9. Rip the CD by clicking on the Extract button.
10.Retest the 1-9 with another GStreamer Pipeline:
"audio/x-raw-int,rate=44100,channels=2 ! lame name=enc vbr=0 bitrate=191 !
id3v2mux".

Result: the mp3 files were extracted normally with the two GStreamer Pipelines.
Sound-juicer did not freeze during the whole operation.

PS: The generated mp3 files from the above case cannot be played by Totem with
the following error: Could not determine type of stream. But it seems that it is
due to the plugins problem. So verify the bug first. Is there anybody can give
up some advice on the plugins problem? Thanks.

BTW, we got MP3 fluendo plugins from
http://porkchop.devel.redhat.com/brewroot/packages/gstreamer-plugins-fluendo/0.10/7.el5/i386/
and LAME plugin from
http://www.rpmfind.net/linux/RPM/freshrpms/fedora/6/gstreamer-plugins-ugly/gstreamer-plugins-ugly-0.10.5-1.fc6.i386.html
Comment 5 Nicole Dai 2007-01-08 04:00:14 EST
After installed the following packages, the plugin problem was fixed. Resolve
the bug now. Pls feel free to reopen this bug report if the solution does not
work for you.
amrnb-0.0.1-2.fc6
libdvdcss-1.2.9-4.lvn6
libdvdread-0.9.7-4.fc6.at
libid3tag-0.15.1b-3.fc6.rf
libmad0-0.15.1b-3.fc6.at
libmp3lame0-3.97-15.fc6.at
libsidplay-1.36.59-1.2.fc6.rf
mpeg2dec-0.4.1-2.lvn6
liba52_0-0.7.4-7.fc6.at
gstreamer-plugins-ugly-0.10.5-1.fc6.rf
gstreamer-plugins-fluendo-video-0.10-7.el5
gstreamer-tools-0.10.9-3.el5
gstreamer-plugins-base-0.10.9-6.el5
gstreamer-plugins-good-0.10.4-2.el5
gstreamer-plugins-fluendo-windowsmedia-0.10-7.el5
gstreamer-plugins-fluendo-mp3-0.10-7.el5
gstreamer-0.10.9-3.el5

Note You need to log in before you can comment on or make changes to this bug.