Bug 216823 - Avoid speed variations, too slow ripping
Avoid speed variations, too slow ripping
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: sound-juicer (Show other bugs)
5.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Alexander Larsson
: Desktop
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-21 23:55 EST by Matthias Clasen
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version: 5.0.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-01-15 09:56:14 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 343544 None None None Never

  None (edit)
Description Matthias Clasen 2006-11-21 23:55:10 EST
This problem was first reported upstream in:
http://bugzilla.gnome.org/show_bug.cgi?id=343544
and a fix is in 2.16.2
Comment 1 Matthias Clasen 2006-11-23 00:11:33 EST
fixed in sound-juicer-2.16.0-3.el5
Comment 2 RHEL Product and Program Management 2006-11-27 21:35:12 EST
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 3 Nicole Dai 2007-01-08 01:37:16 EST
Tested the bug with following environment and test case:
Env:
RHEL5-Client-20061226.nightly
sound-juicer-2.16.0-3.el5
# hdparm -c -d -u -i /dev/cdrom
/dev/cdrom:
 IO_support   =  0 (default 16-bit)
 unmaskirq    =  0 (off)
 using_dma    =  1 (on)
 Model=ASUS DVD-E616A2, FwRev=1.02, SerialNo=
 Config={ Fixed Removeable DTR<=5Mbs DTR>10Mbs nonMagnetic }
 RawCHS=0/0/0, TrkSize=0, SectSize=0, ECCbytes=0
 BuffType=unknown, BuffSize=0kB, MaxMultSect=0
 (maybe): CurCHS=0/0/0, CurSects=0, LBA=yes, LBAsects=0
 IORDY=yes, tPIO={min:383,w/IORDY:120}, tDMA={min:120,rec:120}
 PIO modes:  pio0 pio1 pio2 pio3 pio4 
 DMA modes:  mdma0 mdma1 mdma2 
 UDMA modes: udma0 udma1 udma2 
 AdvancedPM=no

Test Case:
1. click on Edit Profiles, click New and name the profile MP3.Select the MP3
profile and click the Edit button. Set GStreamer Pipeline to
audio/x-raw-int,rate=44100,channels=2 ! lame name=enc vbr=0 bitrate=196 ! id3v2mux
2.Set the File Extension to mp3, and select the Active check box. You will have
to restart Sound Juicer to see the new audio profile.
3. Rip the CD, in Sound Juicer , Disc -> Extract

Result:CD ripping speed is about 2.5x-3.5x.
PS: It rips the Audio CDs at about 3.7x to the ogg format. 
I feel the speed is still a little bit slow. Is there anybody can take a look at
the result? Thanks.
Comment 4 Nicole Dai 2007-01-08 23:24:33 EST
Tested the previous test case twice in another test machine with another CD:
RHEL5-Client-20061226.nightly
sound-juicer-2.16.0-3.el5
# hdparm -c -d -u -i /dev/dvdwriter

/dev/dvdwriter:
 IO_support   =  0 (default 16-bit)
 unmaskirq    =  0 (off)
 using_dma    =  1 (on)

 Model=BENQ DVD DD DW1650, FwRev=BCAC, SerialNo=KWCC512567CC0
 Config={ Fixed Removeable DTR<=5Mbs DTR>10Mbs nonMagnetic }
 RawCHS=0/0/0, TrkSize=0, SectSize=0, ECCbytes=0
 BuffType=unknown, BuffSize=0kB, MaxMultSect=0
 (maybe): CurCHS=0/0/0, CurSects=0, LBA=yes, LBAsects=0
 IORDY=on/off, tPIO={min:120,w/IORDY:120}, tDMA={min:120,rec:120}
 PIO modes:  pio0 pio1 pio2 pio3 pio4 
 DMA modes:  mdma0 mdma1 mdma2 
 UDMA modes: udma0 udma1 *udma2 
 AdvancedPM=no

GStreamer Pipeline: 
audio/x-raw-int,rate=44100,channels=2 ! lame name=enc bitrate=128 ! id3mux

Result:CD ripping speed has been keeping from 13.5x to 25.1x. The speed this
time is acceptable. But another issue is I did not find "id3 tags added to
mp3's" because I added ! id3mux in the GStreamer Pipeline. Is there anybody can
comment on this issue?

As the speed is acceptable verify the bug first.
Comment 5 Jay Turner 2007-01-15 09:56:14 EST
sound-juicer-2.16.0-3.el5 included in 20070111.1 and 20070112.3.

Note You need to log in before you can comment on or make changes to this bug.