Bug 216838 - UP kernel is actually SMP and causes HW problems
UP kernel is actually SMP and causes HW problems
Status: CLOSED DUPLICATE of bug 199877
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
6
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-22 01:50 EST by Cameron Harr
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-27 12:39:14 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Bugzilla 199877 None None None Never

  None (edit)
Description Cameron Harr 2006-11-22 01:50:10 EST
Description of problem:
The FC6 kernel rpm, which should be a UP kernel, is actually an SMP kernel. I've
seen on forums that this is possibly intentional for FC6, but it can cause
problems. In my case there were APIC problems, causing the mouse to be extremely
slow and jumpy. After lots of trial and error, a "noapic" boot option resolved
the problem, but I've been told a UP kernel is going to be better for a UP
system. At any rate, my specific symptom is documented here:
http://forums.fedoraforum.org/showthread.php?p=686280#post686280
and included in an earlier bug here:
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=199877

My main hardware is:
Athlon XP1700+
MSI KT266 Pro2

Version-Release number of selected component (if applicable):
FC6 (multiple kernels), currently 2.6.18-1.2849.fc6

How reproducible:
Always:
[me@mybox ~]$ uname -a
Linux xxx.xxx.xxx 2.6.18-1.2849.fc6 #1 SMP Fri Nov 10 12:45:28 EST 2006 i686
athlon i386 GNU/Linux
[me@mybox ~]$ rpm -q kernel
kernel-2.6.18-1.2849.fc6


Steps to Reproduce:
1.
2.
3.
  
Actual results:
SMP kernel

Expected results:
non-SMP kernel with "kernel-2.6.18-1.2846.fc6"

Additional info:
Comment 1 Jarod Wilson 2006-11-22 10:01:53 EST
(In reply to comment #0)
> Description of problem:
> The FC6 kernel rpm, which should be a UP kernel, is actually an SMP kernel. I've
> seen on forums that this is possibly intentional for FC6

It is intentional, and we're not going to change it.

However, I would suggest double-checking that you actually have an i686 kernel
installed, and not an i586 one, as there was an installer bug that caused this
to happen in some cases. I'm curious if this could be adding to your problem.
See here for details:

http://fedoraproject.org/wiki/Bugs/FC6Common

Out of curiosity, are you by chance also charr@lnxi.com? (asks the former Linux
Networx employee... :)
Comment 2 Cameron Harr 2006-11-22 11:04:14 EST
Jared, right? Yes, as far as I know, I'm still that charr :)

Regarding this issue, I didn't mean to sound so presumptuous that going SMP
should be changed; I'm no expert. It just seemed to me (especially given my
problem) that a UP kernel would be more appropriate. That said, it may be the
arch issue. I don't have access to my box right now, but I'll check that out. Thanks
Comment 3 Jarod Wilson 2006-11-22 11:42:08 EST
Heh, cool. I can't recall if we ever met...

As for the SMP vs. UP issue... Code recently went into the upstream kernel (and
thus the Fedora kernel) that significantly reduced the overhead of running an
SMP-enabled kernel on UP x86 hardware to the point where the gains of an UP-only
kernel were negligible. That being the case, we only ship the SMP-enabled one
now. That'll be the case in RHEL5 too. Definitely curious if this is a
side-effect of the wrong arch kernel running, or if we've got something else to
investigate...
Comment 4 Cameron Harr 2006-11-22 16:37:44 EST
Ok, here is my output. It looks to be real i686 kernel installed. Do you need
anything else? The other associated bug asked me for a dmesg with and without
apic, so I was going to grab that.

[root@chico ~]# uname -a
Linux chico.harr.org 2.6.18-1.2849.fc6 #1 SMP Fri Nov 10 12:45:28 EST 2006 i686
athlon i386 GNU/Linux
[root@chico ~]# rpm -qa --queryformat
"%{NAME}-%{VERSION}-%{RELEASE}.%{ARCH}\n"|grep kernel|sort
kernel-2.6.18-1.2798.fc6.i686
kernel-2.6.18-1.2849.fc6.i686
kernel-devel-2.6.18-1.2798.fc6.i686
kernel-devel-2.6.18-1.2849.fc6.i686
Comment 5 Jarod Wilson 2006-11-27 12:39:14 EST
I think we can close this particular bug as a dupe of bug 199877, since it looks
like they're actually tracking the same problem and you've got the right kernel
installed. I don't have a clue what's up at the moment, but maybe Dan has some
idea of where to go from the info you provided in the other bug...

*** This bug has been marked as a duplicate of 199877 ***

Note You need to log in before you can comment on or make changes to this bug.