Bug 216872 - handle invalid uris without crashing
handle invalid uris without crashing
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: gtk2 (Show other bugs)
5.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Matthias Clasen
David Lawrence
: Desktop
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-22 09:21 EST by Matthias Clasen
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version: 5.0.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-12-04 01:50:47 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matthias Clasen 2006-11-22 09:21:16 EST
This was originally filed upstream as:
http://bugzilla.gnome.org/show_bug.cgi?id=363437
it is a bad bug, since it can cause the panel to crash at startup, rendering
your desktop unusable.

Fixed in upstream cvs
Comment 1 Matthias Clasen 2006-11-22 15:25:30 EST
Fix is in gtk2-2.10.4-6.el5
Comment 2 RHEL Product and Program Management 2006-11-27 21:28:12 EST
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 3 Nicole Dai 2006-12-04 01:48:54 EST
I tried testing the following steps got from
http://bugzilla.gnome.org/show_bug.cgi?id=379863 which is one of duplicates of
http://bugzilla.gnome.org/show_bug.cgi?id=363437 with gtk2-2.10.4-7.el5 on
RHEL5-Client-20061201.0.
1. Open a link like this in epiphany:
http://developer.gnome.org/doc/API/2.0/gtk/GtkRecentManager.html#GtkRecentManager-struct
2. Press <Ctrl>u to see the source
3. In that moment the gnome panel crashes

Test result:
No gnome panel crash occurred. 

As it is difficult to reproduce all crashes filed in 363437 and itsduplicates, I
can just verify the bug according to the above testing. 
Comment 4 Nicole Dai 2006-12-04 01:50:47 EST
As there is no crash found in previous testing and other normal operations,
resolve the bug now.

Note You need to log in before you can comment on or make changes to this bug.