Bug 216884 - gcl: xmaxima can't open socket
Summary: gcl: xmaxima can't open socket
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: gcl (Show other bugs)
(Show other bugs)
Version: 6
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Gérard Milmeister
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 216539
TreeView+ depends on / blocked
 
Reported: 2006-11-22 15:05 UTC by Rex Dieter
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-28 18:34:19 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Rex Dieter 2006-11-22 15:05:53 UTC
+++ This bug was initially created as a clone of Bug #216539 +++

Description of problem:

I can use maxima in the console, but if i start xmaxima i get this error message:

Maxima 5.10.0 http://maxima.sourceforge.net
Using Lisp GNU Common Lisp (GCL) GCL 2.6.7 (aka GCL)
Distributed under the GNU Public License. See the file COPYING.
Dedicated to the memory of William Schelter.
This is a development version of Maxima. The function bug_report()
provides bug reporting information.
(%i1) jfa: starting server on port 4008
couldn't open socket:


Installed packages:
maxima 5.10.0-8.fc6.i386
maxima-gui 5.10.0-8.fc6.i386
maxima-runtime-gcl 5.10.0-8.fc6.i386

-- Additional comment from rdieter@math.unl.edu on 2006-11-22 09:59 EST --
Looks like we're not alone, Ubuntu has the same problem:
https://launchpad.net/distros/ubuntu/dapper/+source/gcl/+bug/43150

Their recommendations were to use a different maxima-runtime (one of
maxima-runtime-clisp, maxima-runtime-cmucl, maxima-runtime-sbcl).

-- Additional comment from rdieter@math.unl.edu on 2006-11-22 10:04 EST --
Upon closer inspection of ubuntu's report, they claim it to be a gcl bug, see
https://launchpad.net/distros/ubuntu/dapper/+source/gcl/+bug/43150/comments/33
https://launchpad.net/distros/ubuntu/dapper/+source/gcl/+bug/43150/comments/34
http://librarian.launchpad.net/4873164/gcl.diff

Comment 1 Rex Dieter 2006-11-28 18:34:19 UTC
closing this (for now), as the bug that prompted it seems to be not reproducible.


Note You need to log in before you can comment on or make changes to this bug.