Bug 216924 - Failing CD-RW drive appears to have hung machine
Failing CD-RW drive appears to have hung machine
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Alan Cox
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-22 13:44 EST by Orion Poplawski
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-24 19:03:37 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Orion Poplawski 2006-11-22 13:44:02 EST
Description of problem:

If there's nothing the kernel can do in this case, feel free to close.  But I
would hope that a failing device that was not in use would not hang the machine.

Here are the messages:

Nov 22 10:56:47 iago kernel: hdd: irq timeout: status=0xd0 { Busy }
Nov 22 10:56:47 iago kernel: ide: failed opcode was: unknown
Nov 22 10:56:47 iago kernel: hdd: DMA disabled
Nov 22 10:56:48 iago kernel: hdd: ATAPI reset complete
Nov 22 10:57:47 iago kernel: hdd: irq timeout: status=0x90 { Busy }
Nov 22 10:57:47 iago kernel: ide: failed opcode was: unknown
Nov 22 10:57:48 iago kernel: hdd: ATAPI reset complete

Nov 22 10:58:53 iago kernel: hdd: irq timeout: status=0x90 { Busy }
Nov 22 10:58:53 iago kernel: ide: failed opcode was: unknown
Nov 22 10:58:53 iago kernel: hdd: status timeout: status=0x90 { Busy }
Nov 22 10:58:53 iago kernel: ide: failed opcode was: unknown
Nov 22 10:58:53 iago kernel: hdd: drive not ready for command
Nov 22 10:58:53 iago kernel: hdd: ATAPI reset complete
Nov 22 10:59:53 iago kernel: hdd: irq timeout: status=0x90 { Busy }
Nov 22 10:59:53 iago kernel: ide: failed opcode was: unknown
Nov 22 10:59:53 iago kernel: hdd: ATAPI reset complete

Nov 22 11:00:58 iago kernel: hdd: irq timeout: status=0x90 { Busy }
Nov 22 11:00:58 iago kernel: ide: failed opcode was: unknown
Nov 22 11:00:58 iago kernel: hdd: status timeout: status=0x90 { Busy }
Nov 22 11:00:58 iago kernel: ide: failed opcode was: unknown
Nov 22 11:00:58 iago kernel: hdd: drive not ready for command
Nov 22 11:00:58 iago kernel: hdd: ATAPI reset complete
Nov 22 11:01:58 iago kernel: hdd: irq timeout: status=0x90 { Busy }
Nov 22 11:01:58 iago kernel: ide: failed opcode was: unknown
Nov 22 11:01:58 iago kernel: hdd: ATAPI reset complete

Nov 22 11:03:03 iago kernel: hdd: irq timeout: status=0x90 { Busy }
Nov 22 11:03:03 iago kernel: ide: failed opcode was: unknown
Nov 22 11:03:03 iago kernel: hdd: status timeout: status=0x90 { Busy }
Nov 22 11:03:03 iago kernel: ide: failed opcode was: unknown
Nov 22 11:03:03 iago kernel: hdd: drive not ready for command
Nov 22 11:03:03 iago kernel: hdd: ATAPI reset complete
Nov 22 11:04:03 iago kernel: hdd: irq timeout: status=0x90 { Busy }
Nov 22 11:04:03 iago kernel: ide: failed opcode was: unknown
Nov 22 11:04:03 iago kernel: hdd: ATAPI reset complete
Nov 22 11:05:03 iago kernel: hdd: irq timeout: status=0x90 { Busy }
Nov 22 11:05:03 iago kernel: ide: failed opcode was: unknown
Nov 22 11:05:08 iago kernel: hdd: status timeout: status=0x90 { Busy }
Nov 22 11:05:08 iago kernel: ide: failed opcode was: unknown
Nov 22 11:05:08 iago kernel: hdd: drive not ready for command
Nov 22 11:05:09 iago kernel: hdd: ATAPI reset complete
Nov 22 11:05:14 iago kernel: hdd: irq timeout: status=0x90 { Busy }
Nov 22 11:05:14 iago kernel: ide: failed opcode was: unknown
Nov 22 11:05:14 iago kernel: hdd: ATAPI reset complete
Nov 22 11:05:19 iago kernel: hdd: irq timeout: status=0x90 { Busy }
Nov 22 11:05:19 iago kernel: ide: failed opcode was: unknown
Nov 22 11:05:24 iago kernel: hdd: status timeout: status=0x90 { Busy }
Nov 22 11:05:24 iago kernel: ide: failed opcode was: unknown
Nov 22 11:05:24 iago kernel: hdd: drive not ready for command
Nov 22 11:05:24 iago kernel: hdd: ATAPI reset complete

Nov 22 11:05:29 iago kernel: hdd: irq timeout: status=0x90 { Busy }
Nov 22 11:05:29 iago kernel: ide: failed opcode was: unknown
Nov 22 11:05:29 iago kernel: hdd: ATAPI reset complete
Nov 22 11:05:34 iago kernel: hdd: irq timeout: status=0x90 { Busy }
Nov 22 11:05:34 iago kernel: ide: failed opcode was: unknown
Nov 22 11:05:39 iago kernel: hdd: status timeout: status=0x90 { Busy }
Nov 22 11:05:39 iago kernel: ide: failed opcode was: unknown
Nov 22 11:05:39 iago kernel: hdd: drive not ready for command
Nov 22 11:05:39 iago kernel: hdd: ATAPI reset complete
Nov 22 11:06:39 iago kernel: hdd: irq timeout: status=0x90 { Busy }
Nov 22 11:06:39 iago kernel: ide: failed opcode was: unknown
Nov 22 11:06:39 iago kernel: hdd: ATAPI reset complete
Nov 22 11:07:44 iago kernel: hdd: irq timeout: status=0x90 { Busy }
Nov 22 11:07:44 iago kernel: ide: failed opcode was: unknown
Nov 22 11:07:44 iago kernel: hdd: status timeout: status=0x90 { Busy }
Nov 22 11:07:44 iago kernel: ide: failed opcode was: unknown
Nov 22 11:07:44 iago kernel: hdd: drive not ready for command
Nov 22 11:07:44 iago kernel: hdd: ATAPI reset complete

Nov 22 11:08:44 iago kernel: hdd: irq timeout: status=0x90 { Busy }
Nov 22 11:08:44 iago kernel: ide: failed opcode was: unknown
Nov 22 11:08:44 iago kernel: hdd: ATAPI reset complete
Nov 22 11:09:49 iago kernel: hdd: irq timeout: status=0x90 { Busy }
Nov 22 11:09:49 iago kernel: ide: failed opcode was: unknown
Nov 22 11:09:49 iago kernel: hdd: status timeout: status=0x90 { Busy }
Nov 22 11:09:49 iago kernel: ide: failed opcode was: unknown
Nov 22 11:09:49 iago kernel: hdd: drive not ready for command
Nov 22 11:09:49 iago kernel: hdd: ATAPI reset complete

Nov 22 11:10:49 iago kernel: hdd: irq timeout: status=0x90 { Busy }
Nov 22 11:10:49 iago kernel: ide: failed opcode was: unknown
Nov 22 11:10:49 iago kernel: hdd: ATAPI reset complete
Nov 22 11:11:49 iago kernel: hdd: irq timeout: status=0x90 { Busy }
Nov 22 11:11:49 iago kernel: ide: failed opcode was: unknown
Nov 22 11:11:54 iago kernel: hdd: status timeout: status=0x90 { Busy }
Nov 22 11:11:54 iago kernel: ide: failed opcode was: unknown
Nov 22 11:11:54 iago kernel: hdd: drive not ready for command
Nov 22 11:11:54 iago kernel: hdd: ATAPI reset complete
Nov 22 11:11:59 iago kernel: hdd: irq timeout: status=0x90 { Busy }
Nov 22 11:11:59 iago kernel: ide: failed opcode was: unknown
Nov 22 11:11:59 iago kernel: hdd: ATAPI reset complete

At this point the display froze and the machine was no longer accessible via the
network.  I'm assuming that this was because problems with the drive.  The drive
was not in use.

Version-Release number of selected component (if applicable):
2.6.18-1.2239.fc5

How reproducible:
Got some drive errors before, but no hang

ide: Assuming 33MHz system bus speed for PIO modes; override with idebus=xx
ICH4: IDE controller at PCI slot 0000:00:1f.1
PCI: Enabling device 0000:00:1f.1 (0005 -> 0007)
ACPI: PCI Interrupt 0000:00:1f.1[A] -> GSI 18 (level, low) -> IRQ 169
ICH4: chipset revision 1
ICH4: not 100% native mode: will probe irqs later
    ide0: BM-DMA at 0xffa0-0xffa7, BIOS settings: hda:DMA, hdb:DMA
    ide1: BM-DMA at 0xffa8-0xffaf, BIOS settings: hdc:DMA, hdd:DMA
Probing IDE interface ide0...
hda: WDC WD300BB-75DEA0, ATA DISK drive
hdb: WDC WD1200BB-00CAA1, ATA DISK drive
ide0 at 0x1f0-0x1f7,0x3f6 on irq 14
Probing IDE interface ide1...
hdc: WDC WD1200BB-00CAA1, ATA DISK drive
hdd: SAMSUNG CD-R/RW SW-240B, ATAPI CD/DVD-ROM drive
ide1 at 0x170-0x177,0x376 on irq 15
hda: max request size: 128KiB
hda: Host Protected Area detected.
        current capacity is 58593750 sectors (30000 MB)
        native  capacity is 58633344 sectors (30020 MB)
hda: Host Protected Area disabled.
hda: 58633344 sectors (30020 MB) w/2048KiB Cache, CHS=58168/16/63, UDMA(100)
hda: cache flushes not supported
 hda: hda1 hda2 hda3
hdb: max request size: 128KiB
hdb: 234441648 sectors (120034 MB) w/2048KiB Cache, CHS=65535/16/63, UDMA(100)
hdb: cache flushes not supported
 hdb: hdb1
hdc: max request size: 128KiB
hdc: 234441648 sectors (120034 MB) w/2048KiB Cache, CHS=65535/16/63, UDMA(100)
hdc: cache flushes not supported
 hdc: hdc1
hdd: ATAPI 40X CD-ROM CD-R/RW drive, 2048kB Cache, UDMA(33)
Uniform CD-ROM driver Revision: 3.20
Comment 1 Dave Jones 2006-11-24 16:28:35 EST
afaik, it is possible to completely lock up the bus if IDE encounters a bad CD
for example.

Alan may be able to give a definitive answer.
Comment 2 Alan Cox 2006-11-24 18:22:21 EST
The 0x90 is ok, staying stuck in 0x90 after a reset means the drive stopped
talking to us. At that point there isn't much we can do. We've spotted the
error, we've asked the device to go back into a sane state and it has not done so.

Alan

Note You need to log in before you can comment on or make changes to this bug.