Bug 216978 - pm-suspend should not look for /sys/power/disk
pm-suspend should not look for /sys/power/disk
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: pm-utils (Show other bugs)
5.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Phil Knirsch
:
Depends On:
Blocks: 235665
  Show dependency treegraph
 
Reported: 2006-11-22 18:09 EST by Matthias Clasen
Modified: 2015-03-04 20:18 EST (History)
2 users (show)

See Also:
Fixed In Version: RHBA-2007-0538
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-07 11:43:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matthias Clasen 2006-11-22 18:09:48 EST
For some reason, the beta2 kernel lost /sys/power/disk on this laptop. 
That is sad. But it shouldn't break suspend. Removing the line

[ -f /sys/power/disk ] || exit 1

from /usr/sbin/pm-suspend makes suspend work again.
Comment 1 Phil Knirsch 2006-11-27 05:08:47 EST
What kind of installation did you make? I've seen this problem with some of the
Zen installations/kernels i've done, and this seems to be intentional that on
Zen kernels some of the /sys/power/ things are missing.

Other than that i agree, for a suspend to ram /sys/power/disk shouldn't be required.

Read ya, Phil
Comment 2 Matthias Clasen 2006-11-27 13:16:54 EST
This was the PAE kernel, not xen.
Comment 3 RHEL Product and Program Management 2006-11-27 21:17:46 EST
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 12 errata-xmlrpc 2007-11-07 11:43:59 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2007-0538.html

Note You need to log in before you can comment on or make changes to this bug.