Bug 216979 - NVIDIA nForce 430 RAID5 detection fails in installer
NVIDIA nForce 430 RAID5 detection fails in installer
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
6
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Peter Jones
http://people.redhat.com/~heinzm/sw/d...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-22 18:15 EST by Henrik Nordstrom
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-30 15:34:02 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Henrik Nordstrom 2006-11-22 18:15:39 EST
Description of problem:

Installer fails with a traceback on Nvidia nForce4 configured in RAID5 mode.

dmesg has the following interesting details:

device-mapper: table 253:0 raid45: unknown type
device-mapper: ioctl: error adding target to device

Version-Release number of selected component (if applicable):

fc6 pxeboot image

How reproducible:


Steps to Reproduce:
1. Configure nForce4 in RAID5
2. Attempt to install Fedora Core 6
3. 
  
Actual results:

traceback, and the above messages in dmesg

Expected results:

raid activated and installation started.

or at least not a traceback only because it failed to activate a raid.

Additional info:
Comment 1 Henrik Nordstrom 2006-11-22 18:19:18 EST
Some hardware details:

Motherboard: Asus M2N-VM DH
CPU: AMD Athlon 64 3500+
Chipset: NVIDIA GeForce 6100 + nForce 430

3 harddrives configured for RAID5 in the NVIDIA Mediashield BIOS setup screen.
Comment 2 Henrik Nordstrom 2006-11-28 14:25:29 EST
Have digged around a little, and it seems the raid45 device mapper module is not
yet in the main kernel or in the Fedora kernel. Apparently available as a patch
from Heinz Mauelshagen, Red Hat GmbH (see the URL).

So there is two issues here.

a) That anaconda unconditionally fails with a traceback if a NVidia RAID5 setup
is encountered, or quite likely if any dmraid related disk setup fails to start
up. Should still work to install on other devices in the same system, but
currently impossible due to Anaconda crashing while detecting the dmraid
"hardware"...

b) That the raid45 module is not in the Fedora kernel making this kinds of raid
not work..

The primary issue is the first I think as it makes it impossible to install even
if one does not plan to install on the RAID:ed drives.

The missing raid45 module is not that criticial, it just means this software
raid is not yet supported by Fedora.


If you want me to test things then I can play with this system for yet another
week. After that I need to bring it into production and testing the NVIDIA raid
support or lack thereof won't be that easy.
Comment 3 Peter Jones 2006-11-30 15:34:02 EST
You can still install, by specifying 'nodmraid' on the boot command line, but
likely the system won't boot until you disable raid in the bis, as the disk
geometry will be different than what bios currently believes it should be.

'a' should be fixed in rawhide; if it sees a raid device we can't handle, it
basically just ignores it.  This is suboptimal, but it's our only real choice.
Comment 4 Henrik Nordstrom 2006-12-01 04:01:00 EST
Excellent. 'a' was my main concern.

I'll give rawhide a try in a few days and report back. The specific system has
both raided and non-raid drives btw.

Note You need to log in before you can comment on or make changes to this bug.