Bug 21701 - RFCs should be packaged in openldap, not openldap-devel
RFCs should be packaged in openldap, not openldap-devel
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: openldap (Show other bugs)
6.2
All Linux
low Severity medium
: ---
: ---
Assigned To: Nalin Dahyabhai
Aaron Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-12-04 17:00 EST by kpinc
Modified: 2007-03-26 23:38 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-12-05 08:57:36 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description kpinc 2000-12-04 17:00:09 EST
In order to know what to put in your ldap database, and how to structure
it, many of the RFC's packaged in openldap-devel should be available to the
openldap user.  Minimally, they should go in openldap-server but many of
them may also be necessary in order to know how to formulate queries, so
you might consider putting them in openldap.

Here's my list of openldap-devel RFC numbers (possibly) needed to run/query
a server:
1308
1309
1558
1384
1778
1779
1781
1959
1960
2247
2254
2255
2256
2293
2294
2307
2377

Some of these are only needed for those who are attempting some sort of
x500 compatibiltiy, which is probably not most people.  Although just
because the RFC talks about x500 it dosen't mean that it's not really
useful in setting up ldap.  I found the x500 executive and techincal
overviews key.  Others, like the ones titled "A String Representation of
LDAP Search Filters" are really handy when querying with a client and may
not really be necessary to set up a server.

In any case, they don't belong in openldap-devel as they are of much wider
use.  Considering that the ldap documentation is so weak, I don't know how
people could set up a server without them.

My list is the result of a quick look-see.  Somebody who knows what they
are doing would surely do a better job.
Comment 1 Daniel Roesen 2000-12-05 08:57:33 EST
Request seconded.
Comment 2 Nalin Dahyabhai 2001-01-12 17:30:12 EST
Um, okay, I'll stick them in the base package (it might be better for -clients,
but I could see the search filter and other things being useful if you're using
nss_ldap, which doesn't need -clients).  This change will be made in 2.0.7-7 and
later.

Note You need to log in before you can comment on or make changes to this bug.