This service will be undergoing maintenance at 20:00 UTC, 2017-04-03. It is expected to last about 30 minutes
Bug 217026 - gaim crash with this error: libnm_glib_nm_state_cb: dbus returned an error
gaim crash with this error: libnm_glib_nm_state_cb: dbus returned an error
Status: CLOSED DUPLICATE of bug 217335
Product: Fedora
Classification: Fedora
Component: gaim (Show other bugs)
6
ia64 Linux
medium Severity medium
: ---
: ---
Assigned To: Warren Togami
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-23 03:32 EST by Alberto Planas
Modified: 2007-11-30 17:11 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-28 10:32:35 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
gdb output (2.90 KB, text/plain)
2006-11-28 04:34 EST, Igor Jagec
no flags Details

  None (edit)
Description Alberto Planas 2006-11-23 03:32:25 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; es-ES; rv:1.8.0.8) Gecko/20061107 Fedora/1.5.0.8-1.fc6 Firefox/1.5.0.8

Description of problem:
After a yum update, I restart my gaim session with:

$ gaim

but I get this error message:

libnm_glib_nm_state_cb: dbus returned an error.
  (org.freedesktop.DBus.Error.ServiceUnknown) The name org.freedesktop.NetworkManager was not provided by any .service files
[... some spanish text explaining that gaim crash wioth yor fault ...]

Version-Release number of selected component (if applicable):
gaim-2.0.0-0.22.beta5.fc6

How reproducible:
Always


Steps to Reproduce:
1. $ gaim
2.
3.

Actual Results:
libnm_glib_nm_state_cb: dbus returned an error.
  (org.freedesktop.DBus.Error.ServiceUnknown) The name org.freedesktop.NetworkManager was not provided by any .service files

Expected Results:
Run gaim normaly

Additional info:
Comment 1 Igor Jagec 2006-11-23 18:10:37 EST
The same problem here. I even tried to run older versions of Gaim, but the 
result is the same :-/

Here's the output:

$ gaim
libnm_glib_nm_state_cb: dbus returned an error.
  (org.freedesktop.DBus.Error.ServiceUnknown) The name 
org.freedesktop.NetworkManager was not provided by any .service files
Gaim has segfaulted and attempted to dump a core file.
This is a bug in the software and has happened through
no fault of your own.

If you can reproduce the crash, please notify the gaim
developers by reporting a bug at
http://gaim.sourceforge.net/bug.php

Please make sure to specify what you were doing at the time
and post the backtrace from the core file.  If you do not know
how to get the backtrace, please read the instructions at
http://gaim.sourceforge.net/gdb.php

If you need further assistance, please IM either SeanEgn or 
LSchiere (via AIM).  Contact information for Sean and Luke 
on other protocols is at
http://gaim.sourceforge.net/contactinfo.php
Comment 2 Alberto Planas 2006-11-24 02:46:27 EST
Workarround: Download gaim source code from http://gaim.sourceforge.net/
(2.0.0beta5 works). Uncompress the source code package and write:

./configure --prefix=${HOME}/bin/gaim
make && make install

cd ${HOME}/bin/gaim/bin
./gaim &

Comment 3 Warren Togami 2006-11-26 17:20:12 EST
Alberto, this bug is reported against gaim-2.0.0 beta5 as packaged in Fedora. 
There is apparently some bug when it is compiled with dbus support.  Your
comment is not helpful.
Comment 4 Warren Togami 2006-11-27 13:05:57 EST
Testers indicate that the dbus message happens in the terminal when gaim is run
with NetworkManager disabled or removed.  However, there is no crash.

http://gaim.sourceforge.net/gdb.php
Your crash is likely unrelated to the dbus message.  Please install matching
debuginfo and follow the gdb procedure, then attach the results to this report.
Comment 5 Igor Jagec 2006-11-28 04:34:16 EST
Created attachment 142269 [details]
gdb output

That's an gdb output which I got following the instructions on
http://gaim.sourceforge.net/gdb.php
Comment 6 Igor Jagec 2006-11-28 04:36:03 EST
(In reply to comment #5)
> Created an attachment (id=142269) [edit]
> gdb output
> 
> That's an gdb output which I got following the instructions on
> http://gaim.sourceforge.net/gdb.php

And yes, I have NetworkManager removed.
Comment 7 Warren Togami 2006-11-28 10:32:35 EST

*** This bug has been marked as a duplicate of 217335 ***

Note You need to log in before you can comment on or make changes to this bug.