Bug 217051 - kudzu doesn't find the device file for USB CDC ACM modems
kudzu doesn't find the device file for USB CDC ACM modems
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kudzu (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-23 09:35 EST by Alex Kanavin
Modified: 2014-03-16 23:04 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-28 12:05:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alex Kanavin 2006-11-23 09:35:36 EST
Kudzu fails to find the device file for USB ACM modems, and as a result,
system-config-network doesn't find these modems either. I believe the fix is as
simple as adding

__getSysfsDevice((struct device *)t,".","tty:",0);
right next to
__getSysfsDevice((struct device *)t,".","net:",0);
in getUsbDevice() in usb.c
Comment 1 Bill Nottingham 2006-11-27 14:02:07 EST
Have you tested that change? (I don't have that hardware.)
Comment 2 Alex Kanavin 2006-11-28 09:29:10 EST
Yes. Before the change:
>>> kudzu.probe(kudzu.CLASS_MODEM,kudzu.BUS_UNSPEC,kudzu.PROBE_ALL)
[Desc:           Nokia Nokia 6680
Driver:         cdc-acm
Device:         None
]

After the change:
>>> kudzu.probe(kudzu.CLASS_MODEM,kudzu.BUS_UNSPEC,kudzu.PROBE_ALL)
[Desc:           Nokia Nokia 6680
Driver:         cdc-acm
Device:         ttyACM0
]
Comment 3 Bill Nottingham 2006-11-28 12:05:59 EST
You wouldn't happen to have any USB-serial converters (ttyUSBX) and notice if
this works for them? :)

Moving the call to after __getNetworkAddr - otherwise if someone does something
patently silly (names a network device ttyACMX), we'll get bogus data.

Will be in 1.2.62-1, might be in a future FC6 update.
Comment 4 Alex Kanavin 2006-12-21 13:35:25 EST
No I don't :( Looks like all modern Nokia have switched to the USB ACM kind of
interface, and I don't have any other suitable hardware.

Note You need to log in before you can comment on or make changes to this bug.