Bug 217070 - Module not loaded when an SD card is inserted to a TI FlashMedia slot
Summary: Module not loaded when an SD card is inserted to a TI FlashMedia slot
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: udev   
(Show other bugs)
Version: 7
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Harald Hoyer
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-11-23 17:39 UTC by Daniel Qarras
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version: udev-113-11
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-27 06:03:35 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Daniel Qarras 2006-11-23 17:39:06 UTC
Description of problem:
2.6.19rc5-git2 includes a new driver for Texas Instruments FlashMedia driver,
tifm_7xx1.ko, tifm_core.ko, tifm_sd.ko. When inserting an SD card to a TI
FlashMedia card slot, the driver recognizes the card but after that nothing
happens, i.e., the card is not mounted and an icon presented on desktop under GNOME.

Version-Release number of selected component (if applicable):
udev-095-14

How reproducible:
Always.

Steps to Reproduce:
1. Use a 2.6.19 based kernel RPM
2. Insert an SD card to a TI FlashMedia card slot
3. See what happens
  
Actual results:
Only reaction on system just a line in dmesg:

Nov 21 23:27:22 localhost kernel: tifm_7xx1: sd card detected in socket 3


Expected results:
Card recognized and mounted making the file system accessible.

Additional info:
Manually I can mount the file system all ok but this should be handled by
udev/hal/else just as a CD is handled when inserted.

Comment 1 Daniel Qarras 2006-12-28 21:05:26 UTC
Re-tested this with latest udev/kernel packages from rawhide and the problem
still exists. Versions were:

udev-103-3
kernel-2.6.19-1.2891.fc7

Please consider fixing, this affects to thousands of laptop users.

Comment 2 Harald Hoyer 2007-01-10 11:16:51 UTC
Are all of the modules loaded by udev? If yes, then this bug should be assigned
to "hal"

Comment 3 Daniel Qarras 2007-01-10 22:02:58 UTC
Indeed all modules have been loaded after a fresh boot of the machine, even
before a card is inserted.

Comment 4 Daniel Qarras 2007-01-10 22:03:52 UTC
I'll move this from udev to hal as suggested by Harald.

Comment 5 Daniel Qarras 2007-01-19 15:50:12 UTC
Ok, as expected, now this can been be reproduced with official FC6
kernel-2.6.19-1.2895.fc6. The modules are loaded after boot even if no card is
present but when a card is inserted nothing happens, see above. hal is at
version hal-0.5.8.1-6.fc6.

Comment 6 Daniel Qarras 2007-01-19 15:51:32 UTC
Fixing the subject.

Comment 7 Daniel Qarras 2007-01-19 15:56:16 UTC
This is related to Bugzilla Bug 218474: SD media card not mounted at

https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=218474

Comment 8 Daniel Qarras 2007-04-21 13:27:45 UTC
FWIW, Ubuntu 7.04 is working perfectly where both FC6/F7T3 fail.

Comment 9 Daniel Qarras 2007-04-29 11:45:05 UTC
This is still broken with Fedora 7 Test 4 (6.93) but works all ok with Ubuntu 7.04.

Comment 10 Daniel Qarras 2007-05-31 20:57:52 UTC
FWIW, this is still broken with Fedora 7 (but still works all ok with Ubuntu 7.04).

Comment 11 Hans de Goede 2007-06-10 11:34:55 UTC
Are you logged in as root or as normal user?


Comment 12 Daniel Qarras 2007-06-11 15:15:35 UTC
Usually as a normal user. I now tried as root but it still doesn't work.

Comment 13 Daniel Qarras 2007-06-21 13:29:11 UTC
It turned out that tifm_sd module was not loaded. When doing

modprobe tifm_sd

under GNOME an icon for the card appears on desktop and GNOME asks whether to
import photos. Based on Comment #2 I'll move this to udev.

Comment 14 Harald Hoyer 2007-06-26 12:44:31 UTC
tifm_sd cannot be autoloaded by udev, because it has no modaliases.
There have to be custom udev rules for this module or the kernel module should
be fixed.

Comment 15 Daniel Qarras 2007-06-27 05:42:14 UTC
I contacted the author of the module and got this reply:


The udev issue is different from HAL one. I was going to add modaliases
eventually (after memstick is ready), but in the meantime, a custom udev rule
will do (I thought ubuntu people had handled this already):

SUBSYSTEM=="tifm", ACTION=="add", ENV{TIFM_CARD_TYPE}=="SD",
 RUN+="/sbin/modprobe tifm_sd"



Comment 16 Daniel Qarras 2007-06-27 05:55:36 UTC
I can now confirm that adding to the file /etc/udev/rules.d/50-udev.rules the
following just before the final rule fixes this issue:

SUBSYSTEM=="tifm", ACTION=="add", ENV{TIFM_CARD_TYPE}=="SD", \
 RUN+="/sbin/modprobe tifm_sd"

Thanks.


Comment 17 Harald Hoyer 2007-06-27 08:26:47 UTC
Thanks, will include in the next update.

Comment 18 Daniel Qarras 2007-06-27 18:29:04 UTC
A related or the same problem is reported at

https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=232370

Comment 19 Daniel Qarras 2007-08-25 14:01:58 UTC
With latest udev-113-11.fc7 this now works perfectly! After booting F7, I insert
an SD card and an icon appears on my desktop and all needed modules are loaded.

Thanks a lot!


Note You need to log in before you can comment on or make changes to this bug.