Bug 217075 - File ownership on fusermount wrong
File ownership on fusermount wrong
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: fuse (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Peter Lemenkov
Fedora Extras Quality Assurance
:
: 217173 217183 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-23 14:42 EST by jlbartos
Modified: 2007-11-30 17:11 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-26 02:37:29 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description jlbartos 2006-11-23 14:42:20 EST
Description of problem:
The file permissions and ownership of /usr/bin/fusermount are wrong.
They used to be -rwsr-xr--  and are now -rwxr-xr-x .
They used to be root.fuse but are now root.root.

Version-Release number of selected component (if applicable):
fuse-2.6.0-1.fc6

How reproducible:
fuse-sshfs doesn't seem to work with the new permissions and ownership. User is
member of fuse group. 


Steps to Reproduce:
$ sshfs computer.home.lan local_directory/


  
Actual results:
fusermount: mount failed: Operation not permitted

Expected results:
Connection.

Additional info:
Using latest selinux-policy.
Reverting to previous permissions and ownership solved problem.
Didn't change the selinux contex which is:
system_u:object_r:mount_exec_t
Comment 1 jlbartos 2006-11-23 14:48:31 EST
The command should have been:
sshfs computer.home.lan: local_directory/
Comment 2 jlbartos 2006-11-24 13:36:07 EST
Bug 217173 is a double.
Comment 3 Peter Lemenkov 2006-11-25 01:46:25 EST
*** Bug 217183 has been marked as a duplicate of this bug. ***
Comment 4 Peter Lemenkov 2006-11-25 01:46:51 EST
*** Bug 217173 has been marked as a duplicate of this bug. ***
Comment 5 Peter Lemenkov 2006-11-25 05:09:47 EST
Will be fixed in next release. Right now you may use quick and dirty workaround:

$ sudo chmod 4755 /usr/bin/fusermount
Comment 6 Peter Lemenkov 2006-11-26 02:37:29 EST
Fixed in 2.6.0-2

Please, upgrade.

Note You need to log in before you can comment on or make changes to this bug.