Bug 217077 - patches in CVS break quilt
patches in CVS break quilt
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
All Linux
medium Severity low
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-23 14:50 EST by Arnd Bergmann
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-23 17:02:23 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
refreshed version of linux-2.6-devmem.patch (18.03 KB, patch)
2006-11-23 14:50 EST, Arnd Bergmann
no flags Details | Diff
refreshed version of linux-2.6-execshield.patch (60.32 KB, patch)
2006-11-23 14:52 EST, Arnd Bergmann
no flags Details | Diff
refreshed version of linux-2.6-execshield.patch (60.32 KB, patch)
2006-11-23 14:52 EST, Arnd Bergmann
no flags Details | Diff
refreshed version of linux-2.6-proc-self-maps-fix.patch (2.73 KB, text/x-diff)
2006-11-23 14:53 EST, Arnd Bergmann
no flags Details
refreshed version of linux-2.6-proc-self-maps-fix.patch (2.73 KB, patch)
2006-11-23 14:53 EST, Arnd Bergmann
no flags Details | Diff
refreshed version of linux-2.6-squashfs.patch (35.71 KB, patch)
2006-11-23 14:56 EST, Arnd Bergmann
no flags Details | Diff

  None (edit)
Description Arnd Bergmann 2006-11-23 14:50:04 EST
I tried to use 'quilt setup kernel-2.6.spec' to get a working tree out 
of :pserver:anonymous@cvs.fedora.redhat.com:/cvs/dist/rpms/kernel/devel/. It 
works fine, but it's currently not possible to undo some of the patches 
with 'quilt pop', because they patch the same file twice.

I've updated the patches that cause this particular problem locally, and 
verified that they have identical content to those in CVS.
Comment 1 Arnd Bergmann 2006-11-23 14:50:04 EST
Created attachment 142010 [details]
refreshed version of linux-2.6-devmem.patch
Comment 2 Arnd Bergmann 2006-11-23 14:52:10 EST
Created attachment 142011 [details]
refreshed version of linux-2.6-execshield.patch
Comment 3 Arnd Bergmann 2006-11-23 14:52:22 EST
Created attachment 142012 [details]
refreshed version of linux-2.6-execshield.patch
Comment 4 Arnd Bergmann 2006-11-23 14:53:22 EST
Created attachment 142013 [details]
refreshed version of linux-2.6-proc-self-maps-fix.patch
Comment 5 Arnd Bergmann 2006-11-23 14:53:41 EST
Created attachment 142014 [details]
refreshed version of linux-2.6-proc-self-maps-fix.patch
Comment 6 Arnd Bergmann 2006-11-23 14:56:55 EST
Created attachment 142017 [details]
refreshed version of linux-2.6-squashfs.patch

sorry for the duplicated attachments. my web browser was causing trouble.
Comment 7 David Woodhouse 2006-11-23 17:02:23 EST
Committed; thanks.
Comment 8 David Woodhouse 2006-11-23 17:05:18 EST
Apart from the squashfs one, which I've reverted because it's broken -- it's
patching fs/squashfs/inode.c which doesn't exist before the patch.

Note You need to log in before you can comment on or make changes to this bug.