Bug 217093 - Subversion fails on adding lots of files to the repository
Subversion fails on adding lots of files to the repository
Product: Fedora
Classification: Fedora
Component: subversion (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Joe Orton
Depends On:
  Show dependency treegraph
Reported: 2006-11-23 19:14 EST by Bojan Smojver
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-11-27 19:00:20 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Bojan Smojver 2006-11-23 19:14:36 EST
Description of problem:

I have a project with 8800+ files (220+ MB). They are stored in 3 directories.
When I attempt svn add <directories>, all appears fine. However, svn diff |
less, only lists some of those files. Attempt to commit also considers only some
of those files. Doing the same on CentOS4 with subversion 1.1.4-2 client works fine.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Checkout an empty directory from the repository.
2. Create a few source directories with many files (8800+) 220+ MB in size.
3. Add the files to WC (svn add).
4. Attempt to commit to repository (svn commit).
Actual results:
Only some files are shown with 'svn diff'. Only some files are considered for

Expected results:
All files should be in the diff and commited to the repository.

Additional info:
The server is running subversion 1.1.4-2 (CentOS 4 box).
Comment 1 Joe Orton 2006-11-24 04:23:47 EST
A trivial attempt to reproduce fails:

 1031  svn co http://.../repos/foobar/fish
 1032  cd fish/
 1035  for d in 1 2 3; do for m in `seq 1 3000`; do echo random >
dir${d}/file${m}; done; done
 1038  svn add *

Now I get:

jorton@turnip:fish$ svn st | wc -l
jorton@turnip:fish$ svn diff | grep -c ^---

so what is different about your case?  Types, size of file?  repos on svn://? 
i386, x86_64?
Comment 2 Bojan Smojver 2006-11-24 17:22:21 EST
The client in my case was an x86_64 box. The server was an i386 box.

Total size of all files to add was 220+ MB. In your case, the size of all files
to add was only 36+ MB.

The directory structure is also deeper than in your example. The tree goes 6
directories deep, with some of those deep directories holding many files.

Unfortunately, I cannot post the files or the file names, as they are
proprietary software that doesn't belong to me and I'm under NDA. But, they are
all just plain text files. And directory names consist of only lowercase letters
and numbers.
Comment 3 Bojan Smojver 2006-11-26 17:13:58 EST
The size is as reported by "du -sk .".
Comment 4 Joe Orton 2006-11-27 06:14:29 EST
Can you manufacture an equivalent reproduction case?  Or perhaps attach the
output of "tree -s" passed through some sed filter to obscure sensitive filenames?
Comment 5 Bojan Smojver 2006-11-27 16:00:54 EST
Let me work on that...
Comment 6 Bojan Smojver 2006-11-27 18:51:01 EST
Just checked out a fresh repo with no files in it. Added all those files and -
everything worked (i.e. svn st and svn diff showed correct number of items
added). I must be going crazy, as I reproduced the original problem multiple
times with the other repository/checkout...
Comment 7 Bojan Smojver 2006-11-27 19:00:20 EST
And tried again by adding same files to a different directory in the original
repo. Again, no problems. Well, I really am going nuts. Closing this now...

Sorry I wasted your time :-(

Note You need to log in before you can comment on or make changes to this bug.