Bug 217114 - install of RHEL4 U4 uses the “ati” driver rather than the radeon” driver
install of RHEL4 U4 uses the “ati” driver rather than the radeon” driver
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: xorg-x11 (Show other bugs)
4.4
All Linux
medium Severity high
: ---
: ---
Assigned To: Adam Jackson
: Triaged
: 217109 217110 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-23 23:04 EST by LisaWu
Modified: 2012-04-17 14:55 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-17 14:55:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
this the xorg.conf that RHEL4U4 provided, it choose 'ati' rather than "radeon" driver. (2.72 KB, text/plain)
2006-11-23 23:04 EST, LisaWu
no flags Details

  None (edit)
Description LisaWu 2006-11-23 23:04:38 EST
Description of problem:
an install of RHEL4 U4 64b on a ATI ES1000(RN50) system would choose the 
“ati” driver rather than the "radeon” driver in xorg.conf

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.install RHEL4U4 64b on a ATI ES1000(RN50) system
2.check the xorg.conf, 

  
Actual results:
In Device section of xorg.conf, it's "ati" driver other than "radeon" driver

Expected results:
It should use "radeon" driver for ATI ES1000(RN50) system

Additional info:

Can RH update h/w database by adding
"NAME ATI ES1000"
"DRIVER radeon" 
to the file /usr/share/hwdata/Cards

adding
"0x1002 0x515E "Card:ATI ES1000" "Card:ATI ES1000" " 
"0x1002 0x5969 "Card:ATI ES1000" "Card:ATI ES1000" " 
to the file /usr/share/hwdata/pcitable
Comment 1 LisaWu 2006-11-23 23:04:38 EST
Created attachment 142029 [details]
this the xorg.conf that RHEL4U4 provided, it choose 'ati' rather than "radeon" driver.
Comment 2 LisaWu 2006-11-24 01:26:39 EST
the correct information to add to pcitalbe should be:
"0x1002 0x515E "Card:ATI ES1000""
"0x1002 0x5969 "Card:ATI ES1000""

BTW:
poor network :(, 3 bugzillas opened( #217109 & #217110 & #217114) just for the 
same issue. Let's work on #217114. 
Comment 3 LisaWu 2007-02-02 02:48:42 EST
since there will be a RHEL4 update5, we hope this can be fixed in the coming 
update5. Thanks.
Comment 4 Matěj Cepl 2007-02-05 09:47:35 EST
*** Bug 217109 has been marked as a duplicate of this bug. ***
Comment 5 Matěj Cepl 2007-02-05 09:49:29 EST
*** Bug 217110 has been marked as a duplicate of this bug. ***
Comment 6 LisaWu 2007-03-19 22:49:33 EDT
will anybody tell me that this bug is/will be fixed in RHEL4U5? Thanks a lot
Comment 7 Adam Jackson 2007-03-20 16:57:11 EDT
Uh, the 'ati' driver is a wrapper, it loads radeon if it needs to.  Why do you
want this changed?
Comment 8 LisaWu 2007-03-20 21:52:18 EDT
yes, we know 'ati' will actually load 'radeon' to drive chip. however, 
specify 'radeon' in xorg.conf is much more straightforward. our costomers 
request this to be changed. Thanks for your cooperation. 
Comment 9 Adam Jackson 2012-04-17 14:55:19 EDT
No further configuration changes are planned to RHEL4.  RHEL5 and later ship with no xorg.conf by default, so this issue is moot there.

Note You need to log in before you can comment on or make changes to this bug.