Bug 217139 - bn-itrans needs modifications, incorrect mappings & errors
Summary: bn-itrans needs modifications, incorrect mappings & errors
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: m17n-db   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Mayank Jain
QA Contact:
URL:
Whiteboard:
Keywords: i18n
Depends On:
Blocks: 217140
TreeView+ depends on / blocked
 
Reported: 2006-11-24 09:44 UTC by Mayank Jain
Modified: 2007-11-30 22:11 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-03-15 12:39:22 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Mayank Jain 2006-11-24 09:44:03 UTC
Description of problem:
bn-itrans needs modifications, incorrect mappings & errors

Version-Release number of selected component (if applicable):
m17n-db-bengali-1.3.3-39.fc7

How reproducible:
Every time

Erroneous combinations
1. aa^r
2. m.h
3. tt
4. ttb
5. tth
6. tn
7. tb
8. tm
9. tr
10. nt
11. ntu
12. ntb
13. ntr
14. st
15. str
16. Rg

Error 16 is probably a case of typographical error and the combination 
can be written if the combining  characters are correctly typed in from 
the main table of vowels and consonants.

Error 1 is an important one.

Error 2 is confusing as it mentions adding a (U09CD) to the consonant 
when the U09CD is automatically enjoined, thus in effect not resulting 
in any valid input. This can have either of the two interpretations and 
usage method:

@ m = U09AE+U09CD (automatic inclusion of U09CD, which will not be 
explicit in case another consonant or vowel is typed in consecutively)
@ ma.h = U09AE + U09CD + U0985 + U09CD (forced inclusion of U09CD to be 
explicitly present even if a consonant or vowel is typed in. This is 
required in some cases)

Additionally U09AE is used here (and in the charts) as a representation 
of other consonants which can be used in a similar manner.

Comment 1 Mayank Jain 2006-11-24 09:45:57 UTC
Reference link - http://www.aczoom.com/itrans/beng/node4.html

Runa, can you please add more comments if necessary?

Thanks,
Mayank

Comment 2 Jens Petersen 2006-11-26 23:50:40 UTC
bn-itrans.mim is part of upstream m17n-db. It should not be separately
included in m17n-db-indic.

Comment 3 Mayank Jain 2006-11-27 12:16:01 UTC
Issues 3-15 can be resolved by adding a halant to "t" character.
m.h is to be left as it is as per our (runa & me) discussion 

Also, as aa^r is no logical combination, it can be also left out.

Further, since "R" as in itself does not maps to any Bengali character, "Rg" can
also be left out.

Hence, in essence, the only fix to this bug is of adding halant to "t"

Comment 4 Mayank Jain 2006-11-27 12:43:54 UTC
Our earlier patch - bn-itrans-t-182227.patch which seemed coming from bug 182227
is to be modified. The hunk which removes the halant from "t" is to be deleted,
which should solve this problem.

Comment 5 Mayank Jain 2006-11-27 13:17:16 UTC
Fixed in

Build                                     Tag                   Built by
----------------------------------------  --------------------  ----------------
m17n-db-1.3.3-40.fc7                      dist-fc7              majain
m17n-db-1.3.3-38.fc6                      dist-fc6-updates-candidate  majain

Comment 6 Mayank Jain 2006-11-27 13:24:03 UTC
Thanks Runa, for all the needed help :)

Comment 7 A S Alam 2007-03-15 12:39:22 UTC
with comment #3, bug is fixed, tested with following Package:
m17n-db-1.3.4-7.fc7


Note You need to log in before you can comment on or make changes to this bug.