Bug 217199 - syslogd -r broken in 1.4.1-40 (ipv6 patch related?)
syslogd -r broken in 1.4.1-40 (ipv6 patch related?)
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: sysklogd (Show other bugs)
rawhide
All Linux
medium Severity high
: ---
: ---
Assigned To: Peter Vrabec
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-24 20:30 EST by Reuben Farrelly
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-12-10 09:20:28 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Reuben Farrelly 2006-11-24 20:30:39 EST
After upgrading to 1.4.1-40 this morning I've found that my syslog is no longer
running.  It crashes immediately after being started up.

I've tracked this down to the option '-r' which I have specified in
/etc/sysconfig/syslog.

It looks a lot like the IPv6 patch has broken it..

[root@tornado log]# strace /sbin/syslogd -r
execve("/sbin/syslogd", ["/sbin/syslogd", "-r"], [/* 23 vars */]) = 0
brk(0)                                  = 0xebcad000
mmap(NULL, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1, 0) =
0x2b653c3f5000
uname({sys="Linux", node="tornado.reub.net", ...}) = 0
access("/etc/ld.so.preload", R_OK)      = -1 ENOENT (No such file or directory)
open("/etc/ld.so.cache", O_RDONLY)      = 3
fstat(3, {st_mode=S_IFREG|0644, st_size=41461, ...}) = 0
mmap(NULL, 41461, PROT_READ, MAP_PRIVATE, 3, 0) = 0x2b653c3f6000
close(3)                                = 0
open("/lib64/libc.so.6", O_RDONLY)      = 3
read(3, "\177ELF\2\1\1\0\0\0\0\0\0\0\0\0\3\0>\0\1\0\0\0 \332a\377"..., 832) = 832
fstat(3, {st_mode=S_IFREG|0755, st_size=1678936, ...}) = 0
mmap(NULL, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1, 0) =
0x2b653c401000
mmap(NULL, 3461272, PROT_READ|PROT_EXEC, MAP_PRIVATE|MAP_DENYWRITE, 3, 0) =
0x2b653c402000
mprotect(0x2b653c546000, 2097152, PROT_NONE) = 0
mmap(0x2b653c746000, 20480, PROT_READ|PROT_WRITE,
MAP_PRIVATE|MAP_FIXED|MAP_DENYWRITE, 3, 0x144000) = 0x2b653c746000
mmap(0x2b653c74b000, 16536, PROT_READ|PROT_WRITE,
MAP_PRIVATE|MAP_FIXED|MAP_ANONYMOUS, -1, 0) = 0x2b653c74b000
close(3)                                = 0
mmap(NULL, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1, 0) =
0x2b653c750000
arch_prctl(ARCH_SET_FS, 0x2b653c7506f0) = 0
mprotect(0x2b653c746000, 16384, PROT_READ) = 0
mprotect(0x39ff419000, 4096, PROT_READ) = 0
munmap(0x2b653c3f6000, 41461)           = 0
getpid()                                = 10309
chdir("/")                              = 0
brk(0)                                  = 0xebcad000
brk(0xebcce000)                         = 0xebcce000
open("/var/run/syslogd.pid", O_RDONLY)  = 3
fstat(3, {st_mode=S_IFREG|0644, st_size=6, ...}) = 0
mmap(NULL, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1, 0) =
0x2b653c3f6000
read(3, "10120\n", 4096)                = 6
close(3)                                = 0
munmap(0x2b653c3f6000, 4096)            = 0
kill(10120, SIG_0)                      = -1 ESRCH (No such process)
rt_sigaction(SIGTERM, {0xebaa5410, [TERM], SA_RESTORER|SA_RESTART,
0x2b653c432130}, {SIG_DFL}, 8) = 0
clone(child_stack=0, flags=CLONE_CHILD_CLEARTID|CLONE_CHILD_SETTID|SIGCHLD,
child_tidptr=0x2b653c750780) = 10310
rt_sigprocmask(SIG_BLOCK, [CHLD], [], 8) = 0
rt_sigaction(SIGCHLD, NULL, {SIG_DFL}, 8) = 0
rt_sigprocmask(SIG_SETMASK, [], NULL, 8) = 0
nanosleep({300, 0}, 0x7fff6e6b19f0)     = ? ERESTART_RESTARTBLOCK (To be restarted)
--- SIGTERM (Terminated) @ 0 (0) ---
exit_group(0)                           = ?
Process 10309 detached
[root@tornado log]#
Comment 1 Peter Vrabec 2006-11-25 08:09:42 EST
I'm sorry, I used wrong version of the IPv6 patch. It should be alright in 
sysklogd-1.4.1-41.fc7.
Comment 2 Peter Vrabec 2006-11-29 11:58:09 EST
Is it alright with sysklogd-1.4.1-41.fc7?
Comment 3 Reuben Farrelly 2006-11-29 22:13:56 EST
It's better in that it now works, but there is still a problem.  The final
character of each line is now being truncated:

Nov 30 10:32:38 router 107: Nov 30 10:32:37: %LINEPROTO-5-UPDOWN: Line protocol
on Interface Tunnel0, changed state to u
Nov 30 13:57:42 router 108: Nov 30 13:57:41: %LINEPROTO-5-UPDOWN: Line protocol
on Interface Tunnel0, changed state to dow
Nov 30 14:00:32 router 109: Nov 30 14:00:31: %CRYPTO-4-IKMP_NO_SA: IKE message f
rom 218.185.225.89 has no SA and is not an initialization offe
Nov 30 14:00:34 router 110: Nov 30 14:00:33: %LINEPROTO-5-UPDOWN: Line protocol
on Interface Tunnel0, changed state to u

('dow' should be 'down', 'offe' should be 'offer')

This only appears to be happening with traffic which is received over the
network, locally generated syslog traffic is OK.

Comment 4 Peter Vrabec 2006-12-09 13:13:40 EST
Could you test this version of sysklogd please, it should be fixed:

http://people.redhat.com/pvrabec/rpms/sysklogd-1.4.1-42.src.rpm
Comment 5 Reuben Farrelly 2006-12-10 07:57:15 EST
Yes, seems to be fixed in sysklogd-1.4.1-42 and all works fine.

Thanks!
Comment 6 Peter Vrabec 2006-12-10 09:20:28 EST
OK, I have updated sysklogd. It there is any other problem feel free to reopen 
this report or file new one. thnx.

Note You need to log in before you can comment on or make changes to this bug.