Bug 217228 - openldap-2.2.13-6.4E does not build
openldap-2.2.13-6.4E does not build
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: openldap (Show other bugs)
4.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jan Safranek
Jay Turner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-25 06:01 EST by giuseppe bonacci
Modified: 2015-01-07 19:15 EST (History)
2 users (show)

See Also:
Fixed In Version: RHBA-2007-0739
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-15 11:04:19 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
rpmbuild log (66.23 KB, application/octet-stream)
2006-11-25 06:01 EST, giuseppe bonacci
no flags Details

  None (edit)
Description giuseppe bonacci 2006-11-25 06:01:58 EST
Description of problem:
srpm fails to build

Version-Release number of selected component (if applicable):
openldap-2.2.13-6.4E.src.rpm

How reproducible:
rpmbuild --rebuild openldap-2.2.13-6.4E.src.rpm

Additional info:

liblber.so is not found by gcc (invoked by libtool) when linking
build-compat/libraries/libldap{,_r}/.libs/libldap{,_r}.so.2.0.130.
(please see lines no 12590 and 12603) of the attached log file. 

apparently the path to the lber library is not passed to gcc.

I suspect the problem shows up because of the Mar 21 2006 entry 
in the changelog "rebuild, using the system copy of libtool 
for the compat libraries (#183331)"

I'm not sure, because I'm not very familiar with libtool, but I 
guess that LT is not given the path to liblber.so, and looks for 
the shared object in system paths.  if this is true, it means that
- openldap cannot build unless openldap-devel is installed.
- compat ldap libraries are built against the lber library 
  included in the openldap-devel currently installed on the system, 
  which could cause subtle problems.

I'll provide further details if needed.

regards.
-- giuseppe
Comment 1 giuseppe bonacci 2006-11-25 06:01:58 EST
Created attachment 142108 [details]
rpmbuild log
Comment 2 Jan Safranek 2007-06-04 11:01:53 EDT
you are right, the build is broken. Wrong libtool is used and the libraries are
built in wrong order, I will try to fix it in RHEL 4.6.
Comment 3 RHEL Product and Program Management 2007-06-04 11:04:28 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 7 errata-xmlrpc 2007-11-15 11:04:19 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2007-0739.html

Note You need to log in before you can comment on or make changes to this bug.