Bug 217234 - Marking inline functions returning pointers to local static data with default visibilty
Marking inline functions returning pointers to local static data with default...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
rawhide
i386 Linux
medium Severity urgent
: ---
: ---
Assigned To: Caolan McNamara
:
: 217283 217424 217442 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-25 09:00 EST by sangu
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-29 04:13:55 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description sangu 2006-11-25 09:00:37 EST
Description of problem:

===backtrace ===
(gdb) r -writer
Starting program: /usr/lib/openoffice.org2.1/program/soffice.bin -writer
(no debugging symbols found)
[Thread debugging using libthread_db enabled]
[New Thread -1219224736 (LWP 2990)]
warning: Lowest section in /usr/lib/libicudata.so.36 is .gnu.hash at 000000b4
[New Thread -1219363952 (LWP 2993)]
[New Thread 145009552 (LWP 2994)]
[New Thread 155499408 (LWP 2995)]
[New Thread -1247630448 (LWP 2996)]
[New Thread -1315288176 (LWP 2997)]
[New Thread -1335260272 (LWP 2998)]
[Thread -1335260272 (LWP 2998) exited]
[New Thread -1335260272 (LWP 2999)]
[Thread -1335260272 (LWP 2999) exited]

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread -1219224736 (LWP 2990)]
0x004a5ae2 in __queryDeepNoXInterface (pDemandedTDR=0xb679107c, 
    cd=<value optimized out>, that=0xaf01f79c)
    at /usr/src/debug/OOE680_m5/solver/680/unxlngi6.pro/inc/rtl/ustring.hxx:347
347             if ( pData->length != str.pData->length )
Current language:  auto; currently c++
(gdb) bt
#0  0x004a5ae2 in __queryDeepNoXInterface (pDemandedTDR=0xb679107c, 
    cd=<value optimized out>, that=0xaf01f79c)
    at /usr/src/debug/OOE680_m5/solver/680/unxlngi6.pro/inc/rtl/ustring.hxx:347
#1  0x004a77f3 in cppu::WeakImplHelper_query (rType=@0x19dcbb0, cd=0x16682e0, 
    that=0xaf01f79c, pBase=0xaf01f79c)
    at /usr/src/debug/OOE680_m5/cppuhelper/source/implbase_ex.cxx:369
#2  0x070d2f45 in
cppu::WeakImplHelper1<com::sun::star::frame::XTerminateListener>::queryInterface
(this=0xaf01f79c, rType=@0x19dcbb0)
    at
/usr/src/debug/OOE680_m5/solver/680/unxlngi6.pro/inc/cppuhelper/implbase1.hxx:115
#3  0x01744819 in framework::Desktop::addTerminateListener (this=0xb500e058, 
    xListener=@0xbfe23718)
    at
/usr/src/debug/OOE680_m5/solver/680/unxlngi6.pro/inc/com/sun/star/uno/Reference.hxx:67
#4  0x070ffb91 in linguistic::AppExitListener::Activate (this=0xaf01f79c)
    at /usr/src/debug/OOE680_m5/linguistic/source/misc.cxx:860
#5  0x070dffb1 in DicList (this=0xaece9140)
    at /usr/src/debug/OOE680_m5/linguistic/source/dlistimp.cxx:341
#6  0x070e00b3 in DicList_CreateInstance (rSMgr=@0xbfe237d8)
    at /usr/src/debug/OOE680_m5/linguistic/source/dlistimp.cxx:441
#7  0x004b7e55 in cppu::OSingleFactoryHelper::createInstanceEveryTime (
    this=0xaece652c, xContext=@0xb678d114)
    at /usr/src/debug/OOE680_m5/cppuhelper/source/factory.cxx:209
---Type <return> to continue, or q <return> to quit---
#8  0x004b7368 in cppu::OSingleFactoryHelper::createInstanceWithContext (
    this=0xaece652c, xContext=@0xb678d114)
    at /usr/src/debug/OOE680_m5/cppuhelper/source/factory.cxx:241
#9  0x004b7425 in cppu::OFactoryComponentHelper::createInstanceWithContext (
    this=0xaece64f8, xContext=@0xb678d114)
    at /usr/src/debug/OOE680_m5/cppuhelper/source/factory.cxx:513
#10 0x004b9c5e in cppu::ORegistryFactoryHelper::createInstanceEveryTime (
    this=0xaed24c2c, xContext=@0xb678d114)
    at /usr/src/debug/OOE680_m5/cppuhelper/source/factory.cxx:779
#11 0x004b7368 in cppu::OSingleFactoryHelper::createInstanceWithContext (
    this=0xaed24c60, xContext=@0xb678d114)
    at /usr/src/debug/OOE680_m5/cppuhelper/source/factory.cxx:241
#12 0x004b747d in cppu::OFactoryComponentHelper::createInstanceWithContext (
    this=0xaed24c2c, xContext=@0xb678d114)
    at /usr/src/debug/OOE680_m5/cppuhelper/source/factory.cxx:517
#13 0x06031a30 in stoc_smgr::OServiceManager::createInstanceWithContext (
    this=0xb678d0c8, rServiceSpecifier=@0xbfe239f8, xContext=@0xb678d114)
    at /usr/src/debug/OOE680_m5/stoc/source/servicemanager/servicemanager.cxx:1307
#14 0x0602c09b in stoc_smgr::OServiceManager::createInstance (this=0xb678d0c8, 
    rServiceSpecifier=@0xbfe239f8)
    at /usr/src/debug/OOE680_m5/stoc/source/servicemanager/servicemanager.cxx:1417
---Type <return> to continue, or q <return> to quit---
#15 0x07100088 in linguistic::GetOneInstanceService (
    pServiceName=0x7113f0c "com.sun.star.linguistic2.DictionaryList")
    at /usr/src/debug/OOE680_m5/linguistic/source/misc.cxx:811
#16 0x07100e5f in linguistic::GetDictionaryList ()
    at /usr/src/debug/OOE680_m5/linguistic/source/misc.cxx:833
#17 0x070f171e in LngSvcMgr::GetListenerHelper_Impl (this=0xaed2d7b0)
    at /usr/src/debug/OOE680_m5/linguistic/source/lngsvcmgr.cxx:806
#18 0x070f19c3 in LngSvcMgr::addLinguServiceManagerListener (this=0xaed2d7b0, 
    xListener=@0xbfe23b38)
    at /usr/src/debug/OOE680_m5/linguistic/source/lngsvcmgr.cxx:1217
#19 0xafabd739 in SwLinguServiceEventListener (this=0xaf0534f4)
    at /usr/src/debug/OOE680_m5/sw/source/ui/uno/dlelstnr.cxx:114
#20 0xaf304bea in SwModule::CreateLngSvcEvtListener (this=0xafc759d0)
    at /usr/src/debug/OOE680_m5/sw/source/ui/app/swmodule.cxx:454
#21 0xaf59700e in SwTxtFrm::_AutoSpell (this=0xaf133000, pActNode=0xaf16005c, 
    rViewOpt=@0xafc89b24, nActPos=1)
    at /usr/src/debug/OOE680_m5/sw/source/core/txtnode/txtedt.cxx:1033
#22 0xaf4c4f93 in SwLayIdle::_DoIdleJob (this=0xbfe23ed4, pCnt=0xaf133000, 
    eJob=SwLayIdle::ONLINE_SPELLING)
    at /usr/src/debug/OOE680_m5/sw/source/core/layout/layact.cxx:2572
#23 0xaf4c51e5 in SwLayIdle::DoIdleJob (this=0xbfe23ed4, 
    eJob=SwLayIdle::ONLINE_SPELLING, bVisAreaOnly=1 '\001')
    at /usr/src/debug/OOE680_m5/sw/source/core/layout/layact.cxx:2663
---Type <return> to continue, or q <return> to quit---
#24 0xaf4c7709 in SwLayIdle (this=0xbfe23ed4, pRt=0xaf18e9bc, pI=0xaf154158)
    at /usr/src/debug/OOE680_m5/sw/source/core/layout/layact.cxx:2772
#25 0xaf39f768 in ViewShell::LayoutIdle (this=0xaf15b7b0)
    at /usr/src/debug/OOE680_m5/sw/source/core/view/viewsh.cxx:752
#26 0xaf5d2935 in SwDoc::DoIdleJobs (this=0xaf17132c, pTimer=0xaf171418)
    at /usr/src/debug/OOE680_m5/sw/source/core/doc/doclay.cxx:1951
#27 0xaf5d2aa8 in SwDoc::LinkStubDoIdleJobs (pThis=0xaf17132c, 
    pCaller=0xaf171418)
    at /usr/src/debug/OOE680_m5/sw/source/core/doc/doclay.cxx:1926
#28 0x00df708c in Timer::Timeout (this=0xaf171418)
    at /usr/src/debug/OOE680_m5/solver/680/unxlngi6.pro/inc/tools/link.hxx:158
#29 0x00df7279 in Timer::ImplTimerCallbackProc ()
    at /usr/src/debug/OOE680_m5/vcl/source/app/timer.cxx:173
#30 0x0243506a in X11SalData::Timeout (this=0xb6b00aa8)
    at ../inc/saltimer.hxx:80
#31 0x023ad286 in GtkXLib::timeoutFn (data=0xb7525308)
    at /usr/src/debug/OOE680_m5/vcl/unx/gtk/app/gtkdata.cxx:595
#32 0x023ad2c1 in call_timeoutFn (data=0xb7525308)
    at /usr/src/debug/OOE680_m5/vcl/unx/gtk/app/gtkdata.cxx:575
#33 0x01ac07c6 in g_timeout_dispatch (source=0x9c02a38, callback=0x25, 
    user_data=0xb7525308) at gmain.c:3422
#34 0x01ac01f2 in IA__g_main_context_dispatch (context=0x9a614e8)
    at gmain.c:2045
---Type <return> to continue, or q <return> to quit---
#35 0x01ac31cf in g_main_context_iterate (context=0x9a614e8, block=0, 
    dispatch=1, self=0x9a3fa70) at gmain.c:2677
#36 0x01ac3735 in IA__g_main_context_iteration (context=0x9a614e8, may_block=0)
    at gmain.c:2736
#37 0x023aefa1 in GtkXLib::Yield (this=0xb7525308, bWait=true, 
    bHandleAllCurrentEvents=false)
    at /usr/src/debug/OOE680_m5/vcl/unx/gtk/app/gtkdata.cxx:722
#38 0x02442db7 in X11SalInstance::Yield (this=0xb6b00a58, bWait=true, 
    bHandleAllCurrentEvents=false)
    at /usr/src/debug/OOE680_m5/vcl/unx/source/app/salinst.cxx:293
#39 0x00df1148 in Application::Yield (bAllEvents=false)
    at /usr/src/debug/OOE680_m5/vcl/source/app/svapp.cxx:553
#40 0x00df121c in Application::Execute ()
    at /usr/src/debug/OOE680_m5/vcl/source/app/svapp.cxx:516
#41 0x006e9e09 in desktop::Desktop::Main (this=0xbfe24494)
    at /usr/src/debug/OOE680_m5/desktop/source/app/app.cxx:1748
#42 0x00df6c9c in ImplSVMain ()
    at /usr/src/debug/OOE680_m5/vcl/source/app/svmain.cxx:254
#43 0x00df6da5 in SVMain ()
    at /usr/src/debug/OOE680_m5/vcl/source/app/svmain.cxx:295
#44 0x006dac59 in sal_main ()
    at /usr/src/debug/OOE680_m5/desktop/source/app/main.cxx:80
#45 0x006dace4 in main (argc=Cannot access memory at address 0xc381ffff
)
---Type <return> to continue, or q <return> to quit---
    at /usr/src/debug/OOE680_m5/desktop/source/app/main.cxx:74
#46 0x00a7ee5c in __libc_start_main (main=0x8048424 <main@plt>, argc=2, 
    ubp_av=0xbfe245a4, init=0x8048520 <__libc_csu_init>, 
    fini=0x8048510 <__libc_csu_fini>, rtld_fini=0x3d7490 <_dl_fini>, 
    stack_end=0xbfe2459c) at libc-start.c:222
#47 0x08048481 in _start ()


Version-Release number of selected component (if applicable):
2.1.0-5.1

How reproducible:
always

Steps to Reproduce:
1. Execute openoffice.
2. Input
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Caolan McNamara 2006-11-27 05:18:52 EST
*** Bug 217283 has been marked as a duplicate of this bug. ***
Comment 2 Caolan McNamara 2006-11-27 10:44:52 EST
fix for bug 214904 is clearly totally bogus after all, bear with me...
Comment 3 Caolan McNamara 2006-11-28 03:53:01 EST
*** Bug 217442 has been marked as a duplicate of this bug. ***
Comment 4 Caolan McNamara 2006-11-28 03:54:04 EST
*** Bug 217424 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.