Bug 217252 - Emacs incorrectly compiled with fakemail setting
Emacs incorrectly compiled with fakemail setting
Status: CLOSED DUPLICATE of bug 213813
Product: Fedora
Classification: Fedora
Component: emacs (Show other bugs)
6
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Chip Coldwell
:
: 217253 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-25 18:47 EST by Eli Barzilay
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-29 10:38:09 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Eli Barzilay 2006-11-25 18:47:07 EST
Description of problem:

  The pre-packaged emacs that comes with FC6 (emacs-21.4-17) is incorrectly
  compiled to use the inexistent "fakemail".

Version-Release number of selected component (if applicable):

  emacs-21.4-17

How reproducible:

  Always.

Steps to Reproduce:
1. Start Emacs (can add -q and --no-site-init to be even more sure).
2. Evaluate `sendmail-program' in Emacs
  
Actual results:

  "fakemail"

Expected results:

  "/usr/sbin/sendmail"

Additional info:

  The problem comes from /usr/share/emacs/21.4/lisp/paths.el which defines
  `sendmail-program' as a constant (see line 164) based on the existence of
  a sendmail executable.  My guess is that the build happens in a clean
  environment that does not have a sendmail executable, so this constant gets
  the default "fakemail" value.  Later on, when the Emacs image is dumped, the
  constant is inlined into it (you cen verify that the packaged
  /usr/bin/emacs-x file contains "fakemail" -- so it becomes a permanent part
  of the distributed Emacs.

  (Somehow, this did manage to send emails on my system (where the only
  "fakemail" executable is from Xemacs), but the problem is that fakemail
  inserts an extra newline in the headers, making it ignore the real headers.)
Comment 1 Eli Barzilay 2006-11-25 18:49:39 EST
*** Bug 217253 has been marked as a duplicate of this bug. ***
Comment 2 Chip Coldwell 2006-11-29 10:38:09 EST

*** This bug has been marked as a duplicate of 213813 ***

Note You need to log in before you can comment on or make changes to this bug.