Bug 217303 - PCRE is not built with --enable-unicode-properties
Summary: PCRE is not built with --enable-unicode-properties
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: pcre   
(Show other bugs)
Version: 6
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Ngo Than
QA Contact: Ben Levenson
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-11-26 20:27 UTC by Dan Siemon
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-27 19:47:48 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Dan Siemon 2006-11-26 20:27:02 UTC
PCRE in FC6 is not built with the --enable-unicode-properties option.  Without
this option the \P, \p, and \X sequences that recognize Unicode character
properties are not supported.

This effects PHP since the Unicode sequences as documented at
http://ca.php.net/manual/en/reference.pcre.pattern.syntax.php
do not work.

These sequences are very useful for validating form input.

More information available at:
http://www.pcre.org/readme.txt

Comment 1 Ngo Than 2006-11-27 19:47:48 UTC
it's now fixed in rawhide. I will build it for FC5/FC6 update soon. Thanks for 
your report.


Note You need to log in before you can comment on or make changes to this bug.