Bug 217315 - rhythmbox crashes on startup, additionally "rhythmbox.debug" does not match "/usr/bin/rhythmbox
rhythmbox crashes on startup, additionally "rhythmbox.debug" does not match "...
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: rhythmbox (Show other bugs)
6
athlon Linux
medium Severity high
: ---
: ---
Assigned To: Ray Strode [halfline]
:
Depends On:
Blocks: 217325
  Show dependency treegraph
 
Reported: 2006-11-26 18:31 EST by Hal Canary
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-01-30 10:44:13 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Hal Canary 2006-11-26 18:31:50 EST
Description of problem:

rhythmbox is crashing on startup.  See
http://bugzilla.gnome.org/show_bug.cgi?id=378591 for more information.

ADDITIONAL PROBLEM:  I've installed the rhythmbox-debuginfo package to help
figure out what's going on.  There's a problem with that:

[~]$ rhythmbox 

** (bug-buddy:3694): WARNING **: Couldn't load icon for Open Folder

warning: the debug information found in
"/usr/lib/debug//usr/bin/rhythmbox.debug" does not match "/usr/bin/rhythmbox"
(CRC mismatch).

[~]$ rpm -q rhythmbox rhythmbox-debuginfo 
rhythmbox-0.9.5-7.fc6
rhythmbox-debuginfo-0.9.5-4.fc6
[~]$ 

the rhythmbox rhythmbox-debuginfo have different versions (0.9.5-7 versus
0.9.5-4).  Is that a problem?



How reproducible:

Every damn time since it started.

Steps to Reproduce:
1. launch rhytmbox
  
Actual results:

bug buddy immediately starts up.
Comment 1 Matthias Clasen 2006-11-26 21:03:50 EST
Comment from the upstream bug:

This is a bug in a fedora patch, rhythmbox-0.9.5-fix-keybinding.patch

In the function modifiers_to_xmodifiers, it uses 'j' before initializing it:

    new_xmodifiers = 0;
    for (i = 0; modifier_mapping[i].type != (GdkModifierType) 0; i++) {
            if (modifiers & modifier_mapping[i].type) {
                    Atom atom;

                    if (modifier_mapping[j].xmodifier_mask != 0) {  // <-- here
                            new_xmodifiers |=
modifier_mapping[i].xmodifier_mask;
                            continue;
                    }

                    .. continuing code that actually initializes 'j'..




Reassigning to Ray, since that is his patch. 

Ray, the same issue is in the rhythmbox-0.9.6-fix-keybinding.patch in rawhide,
and in rhythmbox-0.9.5-fix-keybinding.patch in FC6/RHEL5

Comment 2 Ray Strode [halfline] 2006-11-26 21:24:07 EST
This isn't a problem in rawhide or RHEL-5, I dropped the patch there.

I didn't realize this patch went into fc6.  At one point (before fc6 was
released) I built it into the fc6 branch to do as a post-release update, but
that was after we froze, I thought.  

I'll push an update that should fix this problem.
Comment 3 Ray Strode [halfline] 2006-11-26 22:17:29 EST
Hi Hal,
I've just built rhythmbox-0.9.5-8.fc6 (and control-center-2.16.0-11.fc6) to
address this issue.  When they land in -updates-testing can you grab them and
try them out?
Comment 4 Hal Canary 2006-11-30 07:52:27 EST
I did a "yum --enablerepo=updates-testing -y update rhythmbox" and now
rhythmbox.i386 0:0.9.5-8.fc6 works perfectly for me.  Thanks.
Comment 5 Bastien Nocera 2007-01-30 10:44:13 EST
Thanks for the notice, closing then.

Note You need to log in before you can comment on or make changes to this bug.