Bug 217326 - Uncommitted pre-edit buffer moves with mouse click instead of committing
Uncommitted pre-edit buffer moves with mouse click instead of committing
Status: CLOSED DUPLICATE of bug 222779
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Caolan McNamara
: i18n
: 222635 223426 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-26 22:03 EST by Jong Bae KO
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-28 06:29:22 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Expected results (85.78 KB, image/png)
2006-11-26 22:03 EST, Jong Bae KO
no flags Details
Actual results (84.07 KB, image/png)
2006-11-26 22:04 EST, Jong Bae KO
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenOffice.org 67316 None None None Never

  None (edit)
Description Jong Bae KO 2006-11-26 22:03:01 EST
Description of problem:
In pre-editing state if you click other place, the letter of pre-editing is
moved to clicked place.
It doesn't commit as well(still in pre-editing state).

It might be oowriter bug.
How do you think? Tagoh?


Version-Release number of selected component (if applicable):
openoffice.org-writer-2.0.4-5.5.3
scim-hangul-0.2.2-7.fc6

How reproducible:
always

Steps to Reproduce:
1. run oowriter
2. type "eogksalsrnr" <-  대한민국
3. click between 대 and 한
It doesn't commit as well
  
Actual results:
대국한민

Expected results:
대한민국

Additional info:
Comment 1 Jong Bae KO 2006-11-26 22:03:02 EST
Created attachment 142152 [details]
Expected results
Comment 2 Jong Bae KO 2006-11-26 22:04:11 EST
Created attachment 142153 [details]
Actual results
Comment 3 Jong Bae KO 2006-11-26 22:07:13 EST
This bug is tested in RHEL5, and it shows the same bug.
Comment 4 Akira TAGOH 2006-11-26 23:13:19 EST
This also happens on gedit. need to investigate further.
Comment 5 Akira TAGOH 2006-11-28 03:03:51 EST
Ok, I seem to be misunderstanding and now I see. this bug report contains two
bugs. one is that the committed place is wrong as reported to Bug#217329, which
happens on even GTK+ apps. one is strings not committed at all and preedit line
is kept as is at clicked place, which only happens on OOo, regardless of using
scim or scim-bridge.

Reassigning this to OOo for second issue.
Comment 6 Caolan McNamara 2006-11-28 06:29:22 EST
This is the same as http://qa.openoffice.org/issues/show_bug.cgi?id=67316 and
needs to be considered by upstream, i.e. CANTFIX by me.
Comment 7 Jong Bae KO 2006-12-26 22:23:09 EST
This bug is included CJK language.
Comment 8 Caolan McNamara 2007-01-15 08:13:12 EST
*** Bug 222635 has been marked as a duplicate of this bug. ***
Comment 9 Caolan McNamara 2007-01-19 05:02:43 EST
*** Bug 223426 has been marked as a duplicate of this bug. ***
Comment 10 Caolan McNamara 2007-01-25 07:52:36 EST
*sigh*, if you want something done, sometimes you have to do it yourself

*** This bug has been marked as a duplicate of 222779 ***

Note You need to log in before you can comment on or make changes to this bug.