Bug 217343 - encs doesn't work with fuse 2.6.0
encs doesn't work with fuse 2.6.0
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: fuse-encfs (Show other bugs)
5
All Linux
medium Severity high
: ---
: ---
Assigned To: Peter Lemenkov
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-27 05:13 EST by Andrea Dell'Amico
Modified: 2008-02-10 07:02 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-10 07:02:50 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andrea Dell'Amico 2006-11-27 05:13:42 EST
Description of problem:

encfs doesn't work anymore with fuse 2.6.0


Version-Release number of selected component (if applicable):

The current version of fuse-encfs is 1.3.1-2.fc5


How reproducible:

Update to the latest fuse package, then try to mount an encfs encrypted directory.

Or try "encfs -H", it segfaults

Steps to Reproduce:
1. yum update
2. encfs /encrypted/dir /mount/point
3.
  
Actual results:

Operation fails

Expected results:

Filesystem happily mounted

Additional info:
Comment 1 Robert Marcano 2006-11-27 07:26:38 EST
mounting a previously encrypted filesystem  works for me, but "encfs -H"
segfaults too. running FC6

Linux localhost.localdomain 2.6.18-1.2849.fc6 #1 SMP Fri Nov 10 12:45:28 EST
2006 i686 i686 i386 GNU/Linux
Comment 2 Andrea Dell'Amico 2006-11-27 15:55:05 EST
(In reply to comment #1)
> mounting a previously encrypted filesystem  works for me, but "encfs -H"
> segfaults too. running FC6
> 

You're right, I tried with fuse-2.6.0-1.fc5 only.

With fuse-2.6.0-2.fc5 mounting a filesystem works and "encfs -H" segfaults.
Comment 3 Roland Wolters 2007-02-10 20:56:36 EST
The same is true on my machine [1]. Here is a backtrace:
#0  0x006aeb8c in memcpy () from /lib/libc.so.6
#1  0x0051f28b in fuse_process_cmd () from /usr/lib/libfuse.so.2
#2  0x00529482 in fuse_parse_cmdline () from /usr/lib/libfuse.so.2
#3  0x00529679 in fuse_setup_compat22 () from /usr/lib/libfuse.so.2
#4  0x0804e0f6 in rlog::RLog_Register ()
#5  0x0804ee9b in rlog::RLog_Register ()
#6  0x00656f2c in __libc_start_main () from /lib/libc.so.6
#7  0x0804b1f1 in rlog::RLog_Register ()

[1]My machine:
Linux perricum 2.6.19-1.2895.fc6 #1 SMP Wed Jan 10 19:28:18 EST 2007 i686 i686 
i386 GNU/Linux
fuse-version: fuse-2.6.3-1.fc6, fuse-encfs-1.3.1-3.fc6

Is this problem known upstream?
Comment 4 Peter Lemenkov 2008-01-23 04:25:52 EST
This issue was fixed upstream - new version will be available soon.
Comment 5 Peter Lemenkov 2008-02-10 07:02:50 EST
fuse-encfs-1.4.1.1 acailable in main repository.

Note You need to log in before you can comment on or make changes to this bug.