Bug 217345 - sendmail appears to need an outdates libbind.so.3
sendmail appears to need an outdates libbind.so.3
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: sendmail (Show other bugs)
5
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Thomas Woerner
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-27 06:02 EST by Martin Campbell-Moore
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-28 11:43:53 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Martin Campbell-Moore 2006-11-27 06:02:46 EST
Did the "Holy Grail" for us and upgraded from FC3 to FC4 (All fine) then FC4 to
FC5 and all that breaks is sendmail.

It appears that sendmail for FC5 is linked to libbind.so.3 which we can only
find reference to in FC4 distributions of bind.

Our work around was nasty, just ln -s a link for libbind.so.3 and sendmail is
all happy again. However you can "yum install sendmail" - All is fine until you
try and start (without that link) and it whines about not finding libbind.so.3
(which seems fair as the latest bind is so.4)

Hope that made sense for my first bug submission, hope I didn't wake anyone up
without good cause (and sorry, live updating a box 300 miles away in a room I
cannot access was the only option I had.)
Comment 1 Thomas Woerner 2006-11-27 06:36:22 EST
I am sorry, but sendmail in FC-5 and FC-5-updates does not require bind libs at all.

Please provide the output of 

1) rpm -qa "sendmail*"
2) rpm -Va "sendmail*"
Comment 2 Martin Campbell-Moore 2006-11-27 17:48:47 EST
[root@mail ~]# rpm -qa "sendmail*"
sendmail-8.13.8-1.fc5
[root@mail ~]# rpm -Va "sendmail*"
S.5....TC c /etc/mail/local-host-names
S.5....TC c /etc/mail/sendmail.cf
S.5....TC c /etc/mail/sendmail.mc
SM5....TC c /etc/mail/submit.cf
S.5....TC c /etc/mail/trusted-users
S.5....TC c /etc/mail/virtusertable
S.5....T. c /var/log/mail/statistics
[root@mail ~]# ldd /usr/sbin/sendmail
        linux-gate.so.1 =>  (0x00894000)
        libdb-4.2.so => /lib/libdb-4.2.so (0x003a3000)
    ->  libbind.so.3 => /usr/lib/libbind.so.3 (0x00110000) <-
        libcrypt.so.1 => /lib/libcrypt.so.1 (0x00160000)
        libnsl.so.1 => /lib/libnsl.so.1 (0x0018e000)
        libdl.so.2 => /lib/libdl.so.2 (0x0035c000)
        libssl.so.4 => /lib/libssl.so.4 (0x001a4000)
        libsasl2.so.2 => /usr/lib/libsasl2.so.2 (0x001de000)
        libcrypto.so.4 => /lib/libcrypto.so.4 (0x004f2000)
        libhesiod.so.0 => /usr/lib/libhesiod.so.0 (0x001f6000)
        libwrap.so.0 => /usr/lib/libwrap.so.0 (0x00217000)
        libc.so.6 => /lib/libc.so.6 (0x00610000)
        libpthread.so.0 => /lib/libpthread.so.0 (0x0038b000)
        /lib/ld-linux.so.2 (0x001fc000)
        libgssapi_krb5.so.2 => /usr/lib/libgssapi_krb5.so.2 (0x0021f000)
        libkrb5.so.3 => /usr/lib/libkrb5.so.3 (0x00238000)
        libcom_err.so.2 => /lib/libcom_err.so.2 (0x002ad000)
        libk5crypto.so.3 => /usr/lib/libk5crypto.so.3 (0x002b0000)
        libresolv.so.2 => /lib/libresolv.so.2 (0x002d5000)
        libz.so.1 => /usr/lib/libz.so.1 (0x002e8000)
        libkrb5support.so.0 => /usr/lib/libkrb5support.so.0 (0x002fb000)
Comment 3 Thomas Woerner 2006-11-28 03:30:54 EST
/usr/sbin/sendmail is a link.
Please provide full path information for this link.
Comment 4 Martin Campbell-Moore 2006-11-28 04:45:52 EST
-r-xr-sr-x 1 root smmsp 643460 Apr 10  2006 /usr/sbin/sendmail
Comment 5 Karsten Hopp 2006-11-28 04:59:42 EST
what's the output of 'rpm -qf /usr/sbin/sendmail' ?
/usr/sbin/sendmail usually is a link to /etc/alternatives/mta which in turn
is a link to either /usr/sbin/sendmail.sendmail or /usr/sbin/postfix
Comment 6 Martin Campbell-Moore 2006-11-28 11:14:39 EST
[root@mail ~]# rpm -qf /usr/sbin/sendmail
sendmail-8.13.8-1.fc5
Comment 7 Martin Campbell-Moore 2006-11-28 11:19:56 EST
I suspect we can close this case while I'm off breaking the fingers of a junior
sys-admin ... Now, is there any way of forcing these links to be repaired or do
I manually have to start linking back what the fool has broken?

Sorry for the trouble, I think the following output will show that someone
clearly copied over their own compile of a sendmail binary directly.

[root@mail alternatives]# /usr/sbin/sendmail -d0.1
Version 8.13.6
 Compiled with: DNSMAP HESIOD HES_GETMAILHOST LOG MAP_REGEX MATCHGECOS
                MILTER MIME7TO8 MIME8TO7 NAMED_BIND NETINET NETUNIX NEWDB NIS
                PIPELINING SASLv2 SCANF SOCKETMAP STARTTLS TCPWRAPPERS USERDB

[root@mail alternatives]# /usr/sbin/sendmail.sendmail -d0.1
Version 8.13.8
 Compiled with: DNSMAP HESIOD HES_GETMAILHOST LDAPMAP LOG MAP_REGEX
                MATCHGECOS MILTER MIME7TO8 MIME8TO7 NAMED_BIND NETINET NETINET6
                NETUNIX NEWDB NIS PIPELINING SASLv2 SCANF SOCKETMAP STARTTLS
                TCPWRAPPERS USERDB USE_LDAP_INIT
Comment 8 Thomas Woerner 2006-11-28 11:43:53 EST
Try to use "alternatives --config mta", it might help.

Closing as "NOT A BUG".

Note You need to log in before you can comment on or make changes to this bug.