Bug 21742 - i815
i815
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
7.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-12-05 10:10 EST by yacc
Modified: 2007-04-18 12:30 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-12-05 12:27:01 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description yacc 2000-12-05 10:10:37 EST
I'm a RH user.
I installed RH 7.0 on IBM NetVista, with Acer G772 Monitor.
Graphic card is recognized as i815 (under Win98 is called "Intel 82815"),
but when running X it seems to have some noise as it was an
electromagnetical interference (for example when a mobile phone ringing
close the monitor), especially when move mouse or HD is running. 
I queried yet the current database and found a similar problem about a i810
flickering, and I tried "Xconfigurator --nodri" but did not help).
Thanks for help.
Comment 1 Bill Nottingham 2000-12-05 10:56:26 EST
If it happens when you move the mouse or the hard drive has
activity, it sounds like your machine may have some sheilding
problems.

Are you using a keyboard/mouse switch, or a monitor extension
cable?
Comment 2 yacc 2000-12-05 12:26:57 EST
Sorry! 
I just discovered that what Win98 calls "Intel 82815" is in fact an "Intel 815e 
Solano" (IBM PC model is NetVista 6578-LCG), and from hardware compatibility 
list it is not yet supported.
Microsoft deceived me once again :-((
Comment 3 Mike A. Harris 2000-12-06 09:32:03 EST
The Intel i815 is as you discovered not supported by XFree86 currently.
Perhaps some future release of XFree will support this chip.  Sorry I
can't offer much advice other than waiting...
Comment 4 Tomas Mraz 2001-02-08 06:20:56 EST
I have computer with Intel 815 chipset and the problem is that it allows only
low dot clock otherwise the display is noisy. You have to specify low dot clocks
-> lower refresh rates in the X configuration. Otherwise it works fine on my
Redhat 7.0 machine with XFree 4.0.1. They support it as i810 chipset.
Comment 5 yacc 2001-02-08 10:42:32 EST
Could you give me some help on what to change?

Thanks
Comment 6 Tomas Mraz 2001-02-08 11:01:10 EST
I don't know which resolutions you use and which monitor you have (the max.
horizontal and vertical frequencies of it). But here is my setup which should be
good enough for any current 15-17" monitor and I use the 1152x864 and 1024x768
resolutions:

Edit the section "Monitor" in the XF86Config-4 file, remove all lines beginning
with modeline for the mentioned resolutions and add these following:

Modeline "1152x864" 94 1152 1228 1312 1476 864 868 880 896
Modeline "1024x768" 94 1024 1060 1220 1376 768 770 776 814

These modelines are a maximum which I could get from this onboard video chipset.

The first number after the resolution is the dot-clock speed -> 94 MHz is the
maximum I can reach without the noise.

The other numbers you can modify with the help of the xvidtune program.

I hope this helped a bit.

Note You need to log in before you can comment on or make changes to this bug.