Bug 217429 - Something in a11y goes horribly wrong when apps are started as the non-session user
Something in a11y goes horribly wrong when apps are started as the non-sessio...
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: libgnome (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-27 16:19 EST by Bill Nottingham
Modified: 2014-03-16 23:04 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-04-06 01:30:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bill Nottingham 2006-11-27 16:19:28 EST
Description of problem:

So, I did (I forget why):

$ su -
# nautilus-cd-burner --source-iso=<wherever>

This yielded:
GTK Accessibility Module initialized

** (nautilus-cd-burner:9905): CRITICAL **: AT_SPI_REGISTRY was not started at
session startup.

** (nautilus-cd-burner:9905): WARNING **: IOR not set.

** ERROR **: Could not locate registry
aborting...
Bonobo accessibility support initialized
GTK Accessibility Module initialized

** (gnome_segv2:9918): CRITICAL **: AT_SPI_REGISTRY was not started at session
startup.

** (gnome_segv2:9918): WARNING **: IOR not set.

** ERROR **: Could not locate registry
aborting...
Bonobo accessibility support initialized
GTK Accessibility Module initialized

** (gnome_segv2:9919): CRITICAL **: AT_SPI_REGISTRY was not started at session
startup.

** (gnome_segv2:9919): WARNING **: IOR not set.

** ERROR **: Could not locate registry
aborting...
Bonobo accessibility support initialized
GTK Accessibility Module initialized

** (gnome_segv2:9978): CRITICAL **: AT_SPI_REGISTRY was not started at session
startup.

** (gnome_segv2:9978): WARNING **: IOR not set.

** ERROR **: Could not locate registry
aborting...
...

This is reproducible for other gnome apps (gedit, etc).

(gnome-segv recursive crash filed upstream as bug 379915)

a11y is not specifically enabled.

Version-Release number of selected component (if applicable):

libgnome-2.17.0-1.fc7
Comment 1 Ray Strode [halfline] 2007-04-02 15:03:12 EDT
hmm, is this another bug that's just magically disappeared from being ignored
for months? I can't reproduce.
Comment 2 Bill Nottingham 2007-04-06 01:30:19 EDT
Yep, appears to work now.

Note You need to log in before you can comment on or make changes to this bug.