Bug 217430 - /usr/share/pygtk/2.0/defs/gtk-extrafuncs.defs missing from pygtk2-devel
/usr/share/pygtk/2.0/defs/gtk-extrafuncs.defs missing from pygtk2-devel
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: pygtk2 (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Matthew Barnes
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-27 16:24 EST by Orion Poplawski
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version: pygtk2-2.10.3-3.fc6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-30 19:21:47 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 380020 None None None Never

  None (edit)
Description Orion Poplawski 2006-11-27 16:24:19 EST
Description of problem:

While trying to compile plplot:

pygtk-codegen-2.0 --prefix cplplotcanvas --register
/usr/share/pygtk/2.0/defs/gdk.defs --register /usr/share/pygtk/2.0/defs/gtk.defs
--register /usr/share/pygtk/2.0/defs/gnome.defs --register
/usr/share/pygtk/2.0/defs/canvas.defs --override
/builddir/build/BUILD/plplot-5.7.1/bindings/gnome2/python/cplplotcanvas.override
/builddir/build/BUILD/plplot-5.7.1/fedora/bindings/gnome2/python/plplotcanvas.defs
> /builddir/build/BUILD/plplot-5.7.1/fedora/bindings/gnome2/python/cplplotcanvas.c
Traceback (most recent call last):
  File "/usr/share/pygtk/2.0/codegen/codegen.py", line 1707, in ?
    sys.exit(main(sys.argv))
  File "/usr/share/pygtk/2.0/codegen/codegen.py", line 1665, in main
    p.startParsing()
  File "/usr/share/pygtk/2.0/codegen/scmexpr.py", line 114, in startParsing
    self.handle(statement)
  File "/usr/share/pygtk/2.0/codegen/scmexpr.py", line 118, in handle
    getattr(self, cmd)(*tup[1:])
  File "/usr/share/pygtk/2.0/codegen/defsparser.py", line 29, in include
    self.startParsing()
  File "/usr/share/pygtk/2.0/codegen/scmexpr.py", line 114, in startParsing
    self.handle(statement)
  File "/usr/share/pygtk/2.0/codegen/scmexpr.py", line 118, in handle
    getattr(self, cmd)(*tup[1:])
  File "/usr/share/pygtk/2.0/codegen/defsparser.py", line 33, in include
    raise IOError("%s not found in include path %s" % (input_filename, inc_path))
IOError: gtk-extrafuncs.defs not found in include path
['/usr/share/pygtk/2.0/defs', '.']

Version-Release number of selected component (if applicable):
pygtk2-devel-2.10.3-4.fc7.x86_64

The include is coming from ../root/usr/share/pygtk/2.0/defs/gtk-base.defs:

(include "gtk-extrafuncs.defs")
Comment 1 Matthew Barnes 2006-11-27 23:57:28 EST
Turns out this was not a packaging bug as I had originally thought.

Forwarding this upstream along with a patch.  Please refer to:
http://bugzilla.gnome.org/show_bug.cgi?id=380020

Fixed in pygtk2-2.10.3-5.fc7.
Comment 2 Orion Poplawski 2006-11-30 18:00:11 EST
Can a fix be released for FC6 too?
Comment 3 Matthew Barnes 2006-11-30 19:21:47 EST
Sure, also fixed in pygtk2-2.10.3-3.fc6.

Look for it in Fedora Updates Testing in the next day or so.
Comment 4 Johnny Hughes 2007-10-15 17:13:37 EDT
for the record ... needs fixing in RHEL5 too

Note You need to log in before you can comment on or make changes to this bug.