Bug 217495 - libvir: Xen Daemon error : GET operation failed: No such domain test
libvir: Xen Daemon error : GET operation failed: No such domain test
Status: CLOSED DUPLICATE of bug 207166
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: xen (Show other bugs)
5.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Xen Maintainance List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-28 03:39 EST by Paolo Campegiani
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-28 04:39:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
configuration file for xm create (5.37 KB, application/octet-stream)
2006-11-28 03:39 EST, Paolo Campegiani
no flags Details
/var/log/xen/xend.log (4.52 KB, text/plain)
2006-11-28 05:10 EST, Paolo Campegiani
no flags Details

  None (edit)
Description Paolo Campegiani 2006-11-28 03:39:47 EST
Description of problem:

Unable to create a Xen guest domain. I got the subject message every time I try
to create a guest domain.


Version-Release number of selected component (if applicable):
RHEL 5.0 beta2

How reproducible:
Always

Steps to Reproduce:
1. Use virt-install to create a Xen domain

  
Actual results:

What is the name of your virtual machine? test
 How much RAM should be allocated (in megabytes)? 400
 What would you like to use as the disk (path)? /home/test
 Would you like to enable graphics support? (yes or no) no
 What is the install location? nfs:127.0.0.1:/root/RPMS


Starting install...
libvir: Xen Daemon error : GET operation failed: No such domain test
libvir: Xen Daemon error : POST operation failed: (xend.err 'Device 0 (vif)
could not be connected. Hotplug scripts not working.')
Failed to get devices for domain test
Traceback (most recent call last):
  File "/usr/sbin/virt-install", line 406, in ?
    main()
  File "/usr/sbin/virt-install", line 370, in main
    dom = guest.start_install(conscb)
  File "/usr/lib/python2.4/site-packages/virtinst/ParaVirtGuest.py", line 202,
in start_install
    return XenGuest.XenGuest.start_install(self, consolecb)
  File "/usr/lib/python2.4/site-packages/virtinst/XenGuest.py", line 355, in
start_install
    self.domain = self.conn.createLinux(cxml, 0)
  File "/usr/lib/python2.4/site-packages/libvirt.py", line 249, in createLinux
    if ret is None:raise libvirtError('virDomainCreateLinux() failed')
libvirt.libvirtError: virDomainCreateLinux() failed


Expected results:

Creation of a xen domain.

Additional info:

I am able to create a Xen domain using xm create -c /etc/xen/test (attached). 

xend is running. For udevd I have:

root       457  0.0  0.0   2400   840 ?        S<s  08:49   0:00 udevd

Ifconfig show eth0, eth1, lo, peth1, vif0.1, xenbr1. Only the eth? are
configured with an IP address. Host system is a HP DL380 with 4 GB of RAM.
Comment 1 Paolo Campegiani 2006-11-28 03:39:49 EST
Created attachment 142267 [details]
configuration file for xm create
Comment 2 Daniel Veillard 2006-11-28 04:39:59 EST
The error message is a duplicate of 207166
The real reason why the domain doesn't start is somewhere
in the /var/log/xen/xend.log

Closing this bug as duplicate, for the real reason the domain
does not start check the error log and maybe open a bug with the
proper description, assuming it's really a xen bug and not a
description error.

Daniel

*** This bug has been marked as a duplicate of 207166 ***
Comment 3 Paolo Campegiani 2006-11-28 05:10:25 EST
Created attachment 142274 [details]
/var/log/xen/xend.log
Comment 4 Daniel Veillard 2006-11-28 06:26:07 EST
VmError: Device 0 (vif) could not be connected. Hotplug scripts not working.

Clearly this is unrelated to libvir, bug closed.

Note You need to log in before you can comment on or make changes to this bug.