Bug 217513 - compile psmouse as module
compile psmouse as module
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-28 07:06 EST by Honza 'thingie' Bartoš
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version: 2.6.20-1.2925.fc6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-03-27 14:52:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Novell 179702 None None None Never

  None (edit)
Description Honza 'thingie' Bartoš 2006-11-28 07:06:36 EST
Description of problem:
I've got HP nx7400 laptop which has some problem with ACPI (system cannot get
battery state and few other troubles). The known workaround is to unload psmouse
module before shutdown, but fedora core kernel doesn't have psmouse as module,
it's compiled into kernel directly. If it were as module, I wouldn't have to
compile my own kernel and it would save me some work...

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:
psmouse as kernel module

Additional info:
Comment 1 Gérard Milmeister 2007-02-03 06:26:41 EST
I have an HP nc8430 which suffers from the same problem, as do most newer HP
compaq notebooks, as it seems. I could not yet use the psmouse trick, since
psmouse is not a module. It is essential for HP notebook users, since otherwise
many features such as some keys, cpu scaling etc. do not work. Of course,
investigating the issue (something to do with DSDT tables, I have read) and
solving it would be even better. 
Comment 2 Dave Jones 2007-03-19 17:50:28 EDT
Indeed, a better fix would be to figure out *why* having this module loaded
causes this behaviour.  Unloading a module to fix something isn't really a solution.

Please attach your /proc/acpi/dsdt from the affected system.
Adding the Intel ACPI guys to Cc.
Comment 3 Chuck Ebbert 2007-03-19 17:59:17 EDT
I think this was fixed recently. Can the reporters test at least
kernel 2.6.20-1.2925.fc6? Even better would be to wait for 2933
to show up in testing soon, as it has most of 2.6.20.4 in it.


Comment 4 Honza 'thingie' Bartoš 2007-03-19 18:43:16 EDT
With 2.6.20-1.2925.fc6 it seems to be fixed. At least it correctly displays
power state, remaining battery charge and CPU scales to maximal frequency.
Comment 5 Roy-Magne Mo 2007-03-27 13:05:35 EDT
I'm not able to resume from suspend with kernel-2.6.20-1.3023.fc7 on HP Compaq
NX7400, and AFAIK never been. This is rawhide/development.

Adding link to the resolved issue in Novell bugzilla, but it does not seem like
the patches has been upstreamed yet.
Comment 6 Chuck Ebbert 2007-03-27 13:59:48 EDT
(In reply to comment #5)
> I'm not able to resume from suspend with kernel-2.6.20-1.3023.fc7 on HP Compaq
> NX7400, and AFAIK never been. This is rawhide/development.
> 
> Adding link to the resolved issue in Novell bugzilla, but it does not seem like
> the patches has been upstreamed yet.

Where's the link?
Comment 7 Roy-Magne Mo 2007-03-27 14:45:56 EDT
As a external bugzilla reference at the bottom:
https://bugzilla.novell.com/show_bug.cgi?id=179702
Comment 8 Chuck Ebbert 2007-03-27 14:52:55 EDT
The reporter says the bug is fixed for him. Bugs against devel/FC7 need to be
reported separately. Closing this one.
Comment 9 Roy-Magne Mo 2007-03-27 15:01:53 EDT
It was not the original poster that confirmed that bug is fixed. The reason why
the original poster want's to unload the module is explained in Novells
bugzilla, including the fix.
Comment 10 Chuck Ebbert 2007-03-27 15:05:54 EDT
Original poster confirmed the fix in comment #4.  And the fix that went in is
the exact one referenced in the Novell bugzilla -- psmouse does not need to be
built as a module with that applied.
Comment 11 Honza 'thingie' Bartoš 2007-03-27 15:21:43 EDT
I've been using kernel with the fix since my last comment and everything is
working. So I don't need to unload psmouse anymore.

Note You need to log in before you can comment on or make changes to this bug.