Bug 217574 - Netfront is known to have a bug which would cause high-bandwidth transfers to stall.
Netfront is known to have a bug which would cause high-bandwidth transfers to...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel-xen (Show other bugs)
5.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Herbert Xu
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-28 13:55 EST by Stephen Tweedie
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version: 5.0.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-01-26 15:53:16 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stephen Tweedie 2006-11-28 13:55:42 EST
Description of problem:
Reported upstream:

>What version of netback are you running? The one from the 3.0.3 release is
>known to have a bug which would cause high-bandwidth transfers to stall.
>
>The offending function is netback.c:tx_add_credit(). You should be able to
>take the version from xen-unstable and copy it into whatever version of
>netback.c you are using.

Version-Release number of selected component (if applicable):
kernel-2.6.18-1.2747.el5

How reproducible:
100%

Steps to Reproduce:
Reported on xen-devel mailing list as "high bandwidth transfers."  Useage case
was high-performance GL tunnelling over GLX over tcp.

Thread is at 
http://lists.xensource.com/archives/html/xen-devel/2006-11/msg01384.html
  
Actual results:
"domU networking completely freezes, becoming unresponsive to ssh, ping, the
openGL transport, and other services I tried."

Expected results:
No hang.

Additional info:
Not reproduced internally, but upstream reported symptoms are severe enough to
warrant the fix.
Comment 1 Stephen Tweedie 2006-11-28 13:57:49 EST
Claims to be fixed by upstream csets 12262 and 12459 from xen-unstable.
Comment 2 Herbert Xu 2006-11-28 19:20:18 EST
The patches look OK to me.  BTW, this problem only occurs if credit scheduling
is disabled, which unfortunately is the default.
Comment 3 Jay Turner 2006-12-01 08:04:23 EST
Kind of taking this one on blind faith since we don't see it internally.  QE ack
for RHEL5.
Comment 4 Don Zickus 2006-12-05 14:51:54 EST
in 2.6.18-1.2817.el5
Comment 5 Jay Turner 2007-01-26 15:53:16 EST
2.6.18-7.el5 included in 20070125.0.

Note You need to log in before you can comment on or make changes to this bug.