Bug 217605 - Summary: TBe634e670 __init__.py:767:downloadHeader:RepoError: failure: pango-devel-1.14.8-1.fc6.i386.rpm from
Summary: TBe634e670 __init__.py:767:downloadHeader:RepoError: failure: pango-...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: pirut (Show other bugs)
6
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-28 17:25 EST by Waldyr
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-04-09 16:33:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Software Updater error (1.50 KB, text/plain)
2007-01-17 20:57 EST, Stuart Campbell
no flags Details

  None (edit)
Description Waldyr 2006-11-28 17:25:31 EST
Component: Software Updater
Summary: TBe634e670 __init__.py:767:downloadHeader:RepoError: failure: pango-devel-1.14.8-1.fc6.i386.rpm from updates: [Errno 256] No more mirrors to try.

Traceback (most recent call last):
  File "/usr/sbin/pup", line 433, in _apply
    self.applyChanges(self.mainwin)
  File "/usr/lib/python2.4/site-packages/pirut/__init__.py", line 559, in applyChanges
    self.checkDeps(mainwin)
  File "/usr/lib/python2.4/site-packages/pirut/__init__.py", line 324, in checkDeps
    self.populateTs(keepold=0)
  File "/usr/lib/python2.4/site-packages/yum/depsolve.py", line 153, in populateTs
    self.downloadHeader(txmbr.po)
  File "/usr/lib/python2.4/site-packages/yum/__init__.py", line 767, in downloadHeader
    raise Errors.RepoError, saved_repo_error
RepoError: failure: pango-devel-1.14.8-1.fc6.i386.rpm from updates: [Errno 256] No more mirrors to try.

Local variables in innermost frame:
errors: {}
e: [Errno 2] Arquivo ou diretório não encontrado: '//var/cache/yum/updates/headers/pango-devel-1.14.8-1.fc6.i386.hdr'
self: <__main__.PackageUpdater object at 0x871c9cc>
saved_repo_error: failure: pango-devel-1.14.8-1.fc6.i386.rpm from updates: [Errno 256] No more mirrors to try.
repo: updates
checkfunc: (<bound method PackageUpdater.verifyHeader of <__main__.PackageUpdater object at 0x871c9cc>>, (<yum.sqlitesack.YumAvailablePackageSqlite instance at 0x914704c>, 1), {})
local: //var/cache/yum/updates/headers/pango-devel-1.14.8-1.fc6.i386.hdr
po: pango-devel - 1.14.8-1.fc6.i386
Comment 1 Jeremy Katz 2006-11-28 17:59:59 EST
Is this reproducable?
Comment 2 Marcio H Zuchini 2006-11-29 21:02:52 EST
Hi, folks.

Yes, the error is reproducible.
I had the same error when I tried to update my Fedora Core 6 box.

After clicking "OK", the Software Updater crashed (Listing 1). After reading the
report error, I tried a new update unselecting the "Pango-1.14.8" package, but
the Software Updater crashed again (Listing 2).It seemed that no matter what
package I've selected, the Software Updater crashed.

**But** when I tried to update only
"evolution-data-server-1.8.1-2.fc6.i386.rpm", everything goes OK.

I had 22 updates to apply, but didn't try all the combinations... :-( sorry,
lack of time... I need to work tomorrow morning...

Hope it may be useful.
Marcio H.



*********
Listing 1
*********
Component: Software Updater
Summary: TBe634e670 __init__.py:767:downloadHeader:RepoError: failure:
pango-devel-1.14.8-1.fc6.i386.rpm from updates: [Errno 256] No more mirrors to try.

Traceback (most recent call last):
  File "/usr/sbin/pup", line 433, in _apply
    self.applyChanges(self.mainwin)
  File "/usr/lib/python2.4/site-packages/pirut/__init__.py", line 559, in
applyChanges
    self.checkDeps(mainwin)
  File "/usr/lib/python2.4/site-packages/pirut/__init__.py", line 324, in checkDeps
    self.populateTs(keepold=0)
  File "/usr/lib/python2.4/site-packages/yum/depsolve.py", line 153, in populateTs
    self.downloadHeader(txmbr.po)
  File "/usr/lib/python2.4/site-packages/yum/__init__.py", line 767, in
downloadHeader
    raise Errors.RepoError, saved_repo_error
RepoError: failure: pango-devel-1.14.8-1.fc6.i386.rpm from updates: [Errno 256]
No more mirrors to try.

Local variables in innermost frame:
errors: {}
e: [Errno 2] Arquivo ou diretório não encontrado:
'//var/cache/yum/updates/headers/pango-devel-1.14.8-1.fc6.i386.hdr'
self: <__main__.PackageUpdater object at 0x9a2388c>
saved_repo_error: failure: pango-devel-1.14.8-1.fc6.i386.rpm from updates:
[Errno 256] No more mirrors to try.
repo: updates
checkfunc: (<bound method PackageUpdater.verifyHeader of
<__main__.PackageUpdater object at 0x9a2388c>>,
(<yum.sqlitesack.YumAvailablePackageSqlite instance at 0xa4a6ccc>, 1), {})
local: //var/cache/yum/updates/headers/pango-devel-1.14.8-1.fc6.i386.hdr
po: pango-devel - 1.14.8-1.fc6.i386


*********
Listing 2
*********
Component: Software Updater
Summary: TBe634e670 __init__.py:767:downloadHeader:RepoError: failure:
openssl-devel-0.9.8b-8.0.1.fc6.i386.rpm from updates: [Errno 256] No more
mirrors to try.

Traceback (most recent call last):
  File "/usr/sbin/pup", line 433, in _apply
    self.applyChanges(self.mainwin)
  File "/usr/lib/python2.4/site-packages/pirut/__init__.py", line 559, in
applyChanges
    self.checkDeps(mainwin)
  File "/usr/lib/python2.4/site-packages/pirut/__init__.py", line 324, in checkDeps
    self.populateTs(keepold=0)
  File "/usr/lib/python2.4/site-packages/yum/depsolve.py", line 153, in populateTs
    self.downloadHeader(txmbr.po)
  File "/usr/lib/python2.4/site-packages/yum/__init__.py", line 767, in
downloadHeader
    raise Errors.RepoError, saved_repo_error
RepoError: failure: openssl-devel-0.9.8b-8.0.1.fc6.i386.rpm from updates: [Errno
256] No more mirrors to try.

Local variables in innermost frame:
errors: {}
e: [Errno 2] Arquivo ou diretório não encontrado:
'//var/cache/yum/updates/headers/openssl-devel-0.9.8b-8.0.1.fc6.i386.hdr'
self: <__main__.PackageUpdater object at 0x9f1888c>
saved_repo_error: failure: openssl-devel-0.9.8b-8.0.1.fc6.i386.rpm from updates:
[Errno 256] No more mirrors to try.
repo: updates
checkfunc: (<bound method PackageUpdater.verifyHeader of
<__main__.PackageUpdater object at 0x9f1888c>>,
(<yum.sqlitesack.YumAvailablePackageSqlite instance at 0xa9a254c>, 1), {})
local: //var/cache/yum/updates/headers/openssl-devel-0.9.8b-8.0.1.fc6.i386.hdr
po: openssl-devel - 0.9.8b-8.0.1.fc6.i386
Comment 3 Marcio H Zuchini 2006-11-29 21:26:13 EST
Hi again!

Curiosity is killing me... ;-)
I tried another update process with about 10 packages... everything goes OK again...

The crash (apparently) occurs with these packages only (on my FC6-box):
openssl-devel - 0.9.8b-8.0.1.fc6.i386
pango-devel - 1.14.8-1.fc6.i386
pygobject2-devel - 2.12.3-1.fc6.i386
selinux-policy-targeted - 2.4.5-3.fc6.noarch
system-config-soundcard - 2.0.5-2.fc6.noarch
tzdata - 2006p-1.fc6.noarch

All the other packages was updated correctly.

Now I can sleep well!!! ;-)

Marcio H.
Campinas - SP - Brazil
Comment 4 Waldyr 2006-11-30 06:34:47 EST
Thusday,november 30, 9:33. I tried right now and it works quite well, any
problem to download and install.
Comment 5 Stuart Campbell 2007-01-17 20:57:02 EST
Created attachment 145874 [details]
Software Updater error

Error message from the software updater when attempting Apply updates"
Comment 6 Jeremy Katz 2007-04-09 16:33:17 EDT
This is caused by mirrors being out of sync.  Work on mirror manager should help
to make this not occur with Fedora 7.

Note You need to log in before you can comment on or make changes to this bug.