Bug 217618 - Memory leak in udp-local-addr patch
Summary: Memory leak in udp-local-addr patch
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: net-snmp (Show other bugs)
(Show other bugs)
Version: 6
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Radek Vokal
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 217668
TreeView+ depends on / blocked
 
Reported: 2006-11-28 23:30 UTC by Vladislav Bogdanov
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-29 21:27:00 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch with corrected issues (11.83 KB, patch)
2006-11-28 23:30 UTC, Vladislav Bogdanov
no flags Details | Diff

Description Vladislav Bogdanov 2006-11-28 23:30:00 UTC
Description of problem:

Included version of my udp-local-addr patch has one memory leak and one possible
memory error at client-side.
Server-side seems not to be affected.

Additional notes:
Alternative patch seems to be included in mainstream net-snmp-5.4.
http://sourceforge.net/tracker/index.php?func=detail&aid=1509943&group_id=12694&atid=312694

Comment 1 Vladislav Bogdanov 2006-11-28 23:30:00 UTC
Created attachment 142341 [details]
Patch with corrected issues

Comment 2 Radek Vokal 2006-11-29 08:54:29 UTC
As I understand this patch is already in 5.4. Am I right? 5.4 landed in rawhide
yesterday.

Comment 3 Vladislav Bogdanov 2006-11-29 09:37:03 UTC
Seems like alternative patch is.
Not sure.

grep IP_PKTINFO * in snmplib should help.

Anyway, above patch may be needed for previous supported distros (fc6, fc5, etc.).


Comment 4 Radek Vokal 2006-11-29 09:54:30 UTC
Yes, rawhide has this included. I will transfer this bug to FC6 and fix it in FC6. 

Comment 5 Robert Story 2006-11-29 16:47:49 UTC
If an upstream fix is needed, please open a new bug tracker item upstream. Thanks!

Comment 6 Fedora Update System 2006-11-29 21:20:06 UTC
net-snmp-5.3.1-12.fc6 has been pushed for fc6, which should resolve this issue.  If these problems are still present in this version, then please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.