Bug 217644 - Depdncy chk okay yet post-update raises error window. update success "unknown"
Depdncy chk okay yet post-update raises error window. update success "unknown"
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: yumex (Show other bugs)
5
i686 Linux
medium Severity low
: ---
: ---
Assigned To: Tim Lauridsen
Fedora Extras Quality Assurance
http://picasaweb.google.com/csats.pen...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-28 23:08 EST by J. S.
Modified: 2014-01-21 17:56 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-28 06:38:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description J. S. 2006-11-28 23:08:27 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; X11; Linux i686; en) Opera 9.02

Description of problem:
Launch Yumex. Using a profile which, for all intents and purposes, contains the 
popular "Stanton-Finley" repo group, the software is processes its cached meta 
info (approximately 8,600 items typically process here). The first user 
intervention (after launch) directs Yumex to "Update" mode. As illustrated in 
the right-most image at the URL provided, all Update packages have been 
selected for processing, AND added to the processing queue-- yet clearly Yumex 
reports the contrary-- that no packages have been added to the queue (lowever 
left). 

By process of elimination, only those which Yumex reports must be removed for 
dependency problems were deselected.
After several minutes of software downloading and seemingly "processing" the 
queue, the process ends in error. i do not know (without some manual 
investigation) what is the status of the system. It's possible that this is in 
some way related to Fig:2 as I don't believe that issue was ever resolved. 

Version-Release number of selected component (if applicable):
yumex-1.0.3-3.0.fc5

How reproducible:
Always


Steps to Reproduce:
1. launch yumex
2. select all updates and add them to the processing queue
3. process updates (ommitting those packages which YumEx indicates should be 
removed)

Actual Results:
attempt to determine if any updates had processed. return to "Updates" 
selection section to find same state as previous to "processing"

Expected Results:
software updates processed

Additional info:
YUMEX OUTPUT:
Mirrordetection : default
Yum Version : 2.6.1 (/usr/share/yum-cli)
Loading "installonlyn" plugin
Added 2 new packages, deleted 0 old in 0.90 seconds
Added 1 new packages, deleted 0 old in 0.30 seconds
Added 13 new packages, deleted 85 old in 2.85 seconds
Repository initialization completed in 80.58 seconds
Loading "installonlyn" plugin
Using default mirror detection
Using default mirror detection
Using default mirror detection
Using default mirror detection
Writing Mirrorcache to disk
Repository initialization completed in 81.52 seconds
Preparing for install/remove/update
--> Preparing for install
--> Preparing for remove
--> Preparing for a partial update
--> Populating transaction set with selected packages. Please wait.
---> Downloading header for testdisk to pack into transaction set.
---> Package testdisk.i386 0:6.5-2.fc5 set to be updated
---> Downloading header for fontforge to pack into transaction set.
---> Package fontforge.i386 0:20061025-1.fc5 set to be updated
---> Downloading header for php-pear-Date to pack into transaction set.
---> Package php-pear-Date.noarch 0:1.4.7-1.fc5 set to be updated
---> Downloading header for spamassassin to pack into transaction set.
---> Package spamassassin.i386 0:3.1.7-1.fc5 set to be updated
---> Downloading header for traceroute to pack into transaction set.
---> Package traceroute.i386 3:2.0.2-1.fc5 set to be updated
---> Downloading header for avahi-devel to pack into transaction set.
---> Package avahi-devel.i386 0:0.6.11-2.fc5 set to be updated
---> Downloading header for avahi to pack into transaction set.
---> Package avahi.i386 0:0.6.11-2.fc5 set to be updated
---> Downloading header for kile to pack into transaction set.
---> Package kile.i386 0:1.9.3-1.fc5 set to be updated
---> Downloading header for xterm to pack into transaction set.
---> Package xterm.i386 0:213-2.fc5 set to be updated
---> Downloading header for libosip2 to pack into transaction set.
---> Package libosip2.i386 0:3.0.1-2.fc5 set to be updated
---> Downloading header for avahi-sharp to pack into transaction set.
---> Package avahi-sharp.i386 0:0.6.11-2.fc5 set to be updated
---> Downloading header for mysql to pack into transaction set.
---> Package mysql.i386 0:5.0.27-1.fc5 set to be updated
---> Downloading header for mysql-devel to pack into transaction set.
---> Package mysql-devel.i386 0:5.0.27-1.fc5 set to be updated
---> Downloading header for tzdata to pack into transaction set.
---> Package tzdata.noarch 0:2006m-3.fc5 set to be updated
---> Downloading header for tnef to pack into transaction set.
---> Package tnef.i386 0:1.4.3-1.fc5.rf set to be updated
---> Downloading header for mysql-server to pack into transaction set.
---> Package mysql-server.i386 0:5.0.27-1.fc5 set to be updated
---> Downloading header for python-paramiko to pack into transaction set.
---> Package python-paramiko.noarch 0:1.6.4-1.fc5.rf set to be updated
---> Downloading header for avahi-glib to pack into transaction set.
---> Package avahi-glib.i386 0:0.6.11-2.fc5 set to be updated
---> Downloading header for php-idn to pack into transaction set.
---> Package php-idn.i386 0:1.2-1.fc5 set to be updated
---> Downloading header for clisp to pack into transaction set.
---> Package clisp.i386 0:2.41-2.fc5.rf set to be updated
---> Downloading header for pstoedit to pack into transaction set.
---> Package pstoedit.i386 0:3.44-4.fc5 set to be updated
---> Downloading header for mysql-bench to pack into transaction set.
---> Package mysql-bench.i386 0:5.0.27-1.fc5 set to be updated
--> Running transaction check
--> Processing Dependency: libEMF.so.1 for package: pstoedit
--> Processing Dependency: libosip2.so.3 for package: linphone
--> Processing Dependency: libntfs.so.9 for package: testdisk
--> Processing Dependency: libosipparser2.so.3 for package: linphone
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
---> Downloading header for libEMF to pack into transaction set.
---> Package libEMF.i386 0:1.0.3-3.fc5 set to be updated
---> Downloading header for ntfsprogs to pack into transaction set.
---> Package ntfsprogs.i386 0:1.13.1-3.fc5 set to be updated
--> Running transaction check
--> Processing Dependency: libosip2.so.3 for package: linphone
--> Processing Dependency: libosipparser2.so.3 for package: linphone
--> Finished Dependency Resolution
Preparing for install/remove/update
--> Preparing for install
--> Preparing for remove
--> Preparing for a partial update
--> Populating transaction set with selected packages. Please wait.
---> Package spamassassin.i386 0:3.1.7-1.fc5 set to be updated
---> Package tnef.i386 0:1.4.3-1.fc5.rf set to be updated
---> Package traceroute.i386 3:2.0.2-1.fc5 set to be updated
---> Package avahi.i386 0:0.6.11-2.fc5 set to be updated
---> Package testdisk.i386 0:6.5-2.fc5 set to be updated
---> Package php-pear-Date.noarch 0:1.4.7-1.fc5 set to be updated
---> Package python-paramiko.noarch 0:1.6.4-1.fc5.rf set to be updated
---> Package xterm.i386 0:213-2.fc5 set to be updated
---> Package avahi-devel.i386 0:0.6.11-2.fc5 set to be updated
---> Package avahi-glib.i386 0:0.6.11-2.fc5 set to be updated
---> Package php-idn.i386 0:1.2-1.fc5 set to be updated
---> Package fontforge.i386 0:20061025-1.fc5 set to be updated
---> Package avahi-sharp.i386 0:0.6.11-2.fc5 set to be updated
---> Package clisp.i386 0:2.41-2.fc5.rf set to be updated
---> Package pstoedit.i386 0:3.44-4.fc5 set to be updated
---> Package mysql.i386 0:5.0.27-1.fc5 set to be updated
---> Package mysql-devel.i386 0:5.0.27-1.fc5 set to be updated
---> Package tzdata.noarch 0:2006m-3.fc5 set to be updated
---> Package mysql-bench.i386 0:5.0.27-1.fc5 set to be updated
---> Package mysql-server.i386 0:5.0.27-1.fc5 set to be updated
---> Package kile.i386 0:1.9.3-1.fc5 set to be updated
--> Running transaction check
--> Processing Dependency: libEMF.so.1 for package: pstoedit
--> Processing Dependency: libntfs.so.9 for package: testdisk
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
---> Package libEMF.i386 0:1.0.3-3.fc5 set to be updated
---> Package ntfsprogs.i386 0:1.13.1-3.fc5 set to be updated
--> Running transaction check
Downloading Packages:
Checking GPG Signatures:
Running Transaction Test
Finished Transaction Test
Preparing for install/remove/update
--> Preparing for install
--> Preparing for remove
--> Preparing for a partial update
Downloading Packages:
Checking GPG Signatures:
Running Transaction Test
Finished Transaction Test
Transaction Test Succeeded
Running Transaction

Dependency Installed: libEMF.i386 0:1.0.3-3.fc5 ntfsprogs.i386 0:1.13.1-3.fc5
Updated: avahi.i386 0:0.6.11-2.fc5 avahi-devel.i386 0:0.6.11-2.fc5 avahi-
glib.i386 0:0.6.11-2.fc5 avahi-sharp.i386 0:0.6.11-2.fc5 clisp.i386 0:2.41-
2.fc5.rf fontforge.i386 0:20061025-1.fc5 kile.i386 0:1.9.3-1.fc5 mysql.i386 
0:5.0.27-1.fc5 mysql-bench.i386 0:5.0.27-1.fc5 mysql-devel.i386 0:5.0.27-1.fc5 
mysql-server.i386 0:5.0.27-1.fc5 php-idn.i386 0:1.2-1.fc5 pstoedit.i386 0:3.44-
4.fc5 python-paramiko.noarch 0:1.6.4-1.fc5.rf spamassassin.i386 0:3.1.7-1.fc5 
testdisk.i386 0:6.5-2.fc5 tnef.i386 0:1.4.3-1.fc5.rf traceroute.i386 3:2.0.2-
1.fc5 tzdata.noarch 0:2006m-3.fc5 xterm.i386 0:213-2.fc5
Cleanup Download Packages
0 packages removed
Comment 1 J. S. 2006-11-30 03:29:18 EST
YumEx is now completely "broken"; essentially worthless to this system in its
current state. 

Error window appears on startup, immediately. Closing this error window allows
for browsing the GUI navigation icons at the left, however all windows are
'empty'-- except the "Repos" which accurately reflects the user-profile Repo
selections. No user action affects the state but "refresh" in the repos profile
window will cause the same error from startup to appear.

I've added another image to the collection of screen captures available at the
URL provided in the bug info. 
Comment 2 J. S. 2006-11-30 03:35:35 EST
[root@localhost ~]# yum update
rpmdb: PANIC: fatal region error detected; run recovery
error: db4 error(-30977) from dbenv->open: DB_RUNRECOVERY: Fatal error, run
database recovery
error: cannot open Packages index using db3 -  (-30977)
error: cannot open Packages database in /var/lib/rpm
Traceback (most recent call last):
  File "/usr/bin/yum", line 29, in ?
    yummain.main(sys.argv[1:])
  File "/usr/share/yum-cli/yummain.py", line 80, in main
    base.getOptionsConfig(args)
  File "/usr/share/yum-cli/cli.py", line 177, in getOptionsConfig
    self.doConfigSetup(fn=opts.conffile, root=root)
  File "/usr/lib/python2.4/site-packages/yum/__init__.py", line 102, in
doConfigSetup
    self.conf = config.readMainConfig(fn, root)
  File "/usr/lib/python2.4/site-packages/yum/config.py", line 589, in readMainConfig
    vars['releasever'] = _getsysver(earlyconf.installroot, earlyconf.distroverpkg)
  File "/usr/lib/python2.4/site-packages/yum/config.py", line 689, in _getsysver
    idx = ts.dbMatch('provides', distroverpkg)
TypeError: rpmdb open failed
Comment 3 J. S. 2006-12-06 02:55:34 EST
i've had several more "situations" w/ Yumex since i last updated this ticket.

i'll post all of the screen shots at the same location, and the assorted text 
will be listed below.
Comment 4 Tim Lauridsen 2006-12-06 03:16:36 EST
It looks like you rpm db is broken.

This this as root to fix it

rm -f /var/lib/rpm/__db*

rpm --rebuilddb

It look like you have detected some issues in yumex in 1.0.3, I think most of
them  has been fixed in yumex 1.2.x, but it is only working with yum 3.0.x,
currently in  
FC6. My problem is i don't have a FC5 system any more, so i is hard to recreate
the errors and fix it.
Comment 5 Tim Lauridsen 2006-12-06 03:39:22 EST
I have added some comments to the pictures at

http://picasaweb.google.com/csats.pennstate/AllYumAllDay
Comment 6 J. S. 2006-12-06 03:59:23 EST
okay. i'll try your suggestion. i didn't make it back in time to post this text 
part-- i tried putting here, but too many char's for the textfield here...

truncated, this is terminal output after launching YumEx from terminal as root 
(i.e. yumex activity output simultaneously in terminal, as root)

ror: db4 error(-30977) from db->close: DB_RUNRECOVERY: Fatal error, run 
database recovery
rpmdb: PANIC: fatal region error detected; run recovery
error: db4 error(-30977) from db->close: DB_RUNRECOVERY: Fatal error, run 
database recovery
rpmdb: PANIC: fatal region error detected; run recovery
error: db4 error(-30977) from dbenv->close: DB_RUNRECOVERY: Fatal error, run 
database recovery
15:47:54 : Setup Yum : Config
rpmdb: PANIC: fatal region error detected; run recovery
error: db4 error(-30977) from dbenv->open: DB_RUNRECOVERY: Fatal error, run 
database recovery
error: cannot open Packages index using db3 -  (-30977)
error: cannot open Packages database in /var/lib/rpm
Exception in thread Thread-139:
Traceback (most recent call last):
  File "/usr/lib/python2.4/threading.py", line 442, in __bootstrap
    self.run()
  File "/usr/lib/python2.4/site-packages/yumex/yumexUtils.py", line 1435, in run
    self.rc = self.runfunc( *self.args )
  File "/usr/lib/python2.4/site-packages/yumex/yumexBase.py", line 136, in setup
    self.doConfigSetup()
  File "/usr/lib/python2.4/site-packages/yumex/yumexBase.py", line 171, in 
doConfigSetup
    self.conf = readMainConfig(fn, root, self.forceArch)
  File "/usr/lib/python2.4/site-packages/yumex/yumexBase.py", line 1292, in 
readMainConfig
    vars['releasever'] = _getsysver(earlyconf.installroot, 
earlyconf.distroverpkg)
  File "/usr/lib/python2.4/site-packages/yum/config.py", line 689, in _getsysver
    idx = ts.dbMatch('provides', distroverpkg)
TypeError: rpmdb open failed

[root@localhost ~]#

______________________________________________________________________

the "complete" text (same as above, but all output) is here: 
http://fileshare.adesigninteractive.com/bug-reporting/

note, due to the limitations of the amount of text recorded in the terminal 
history, NOT all of the yumex session is shown there.
Comment 7 J. S. 2006-12-07 01:25:05 EST
I "think" it is working now.... ?
http://fileshare.adesigninteractive.com/bug-reporting/success01.html

the URL shows the most recent output of YUMEX after the processing of an
INCOMPLETE group of files in the UPDATE window. 
after a successful processing of Tim's suggestion for the Yum DB (using his
proposed commands, which i let process 'overnight'), i returned to try YumEx
again. THis time, i could tell somethng different was goign on w/ the reading of
the repo cache data ... whatever is goign on there before i actually see the
"Updates" for selecting. At that time, i selected and queued all, which did NOT
work, perhaps because there was so much to process, and i was doing other
things-- when i returned, i had to force YumEx to quit.

i have other shots from regular "yum", but i think everything is working now--
although this only represents a "partial" processing. please view the output
above URL, and revisit the photos because i am going to add those from the
"unsuccessful" process immediately previous to this "successful" action. (photos
linked from url above) please give me ten mins or so to upload the jpg's 
Comment 8 Tim Lauridsen 2006-12-18 02:50:09 EST
Please let me know if there is some outstanding issue not working.
Comment 9 J. S. 2006-12-18 19:13:50 EST
(In reply to comment #8)
> Please let me know if there is some outstanding issue not working.

tim, i experienced a crash just this morning. 

i had YumEx set for auto refresh on startup. the app got itself fully open,
begin processing repos, then crashed immediately. 
i.e. as if soon as a network connection was estalished (soon as the db was
accessed?), the software shutdown-- resulting in a total visible "up-time" of
approximately 2 seconds. then i opened the Terminal and launched YumEx from
there so i would be able to report something-- so i do have some text filed

i am logged into XP currently, or i would attach the info immediately. i will
get it up here asap-- probably later today.
Comment 10 J. S. 2007-01-05 13:27:20 EST
over the course of the past few weeks i recorded several malfunctions, and also
some processess which i thought were a success. because of the amount of
material there, i put it all in one html file with anchors pointing to each
separate yumex output. the links show a one or two word summary in a "tooltip"
for reference. if you need more info on any of what is there, the only thing i
might have would be a screen cap-- which may or may not have more info than
what's in the text output. i know i did several screen caps too-- but there's so
much there, i'll wait for feedback before publishing anything more.

thanks.
http://fileshare.adesigninteractive.com/bug-reporting/inc/yum-update.html
Comment 11 J. S. 2007-02-02 16:40:34 EST
RE: a Forum Moderator recommendation at LinuxQuestions.org
http://www.linuxquestions.org/questions/showthread.php?t=524948

i don't understand the yum reports on my system, but i figure it's most safe to
assume that the system is not up-to-date.

considering my inability to update such items as "clamav", and continuing failed
attempts with components from locations such as rpmfind.net for example, what is
the official recommendation? 

for example-- should i systematically uninstall apps until yum is able to update
what it needs? 

or is there no reason for concern here?

 
Comment 12 J. S. 2007-02-04 12:45:40 EST
i will be following the instructions of a helpful Moderator at linuxquestions.org

the method is focused primarily on the resolve of what this person recognizes as
a yum database issue. it will likely be useful to follow, or at least reference
the thread, beginning with a list of recommended actions. as of this comment
[here at bugzilla] i have not yet executed any of this user's advised actions,
however i intend to do so within the next 48 hours.

http://www.linuxquestions.org/questions/showthread.php?p=2615745#post2615745
anything above [ post #6 ] is superfluous to the specifics of moving forward. 

Note You need to log in before you can comment on or make changes to this bug.