Bug 217693 - Unable to install on machine without DMI information
Summary: Unable to install on machine without DMI information
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: anaconda
Version: 5.0
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
: ---
Assignee: Anaconda Maintenance Team
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-11-29 13:43 UTC by Petter Reinholdtsen
Modified: 2007-11-30 22:07 UTC (History)
0 users

(edit)
Clone Of:
(edit)
Last Closed: 2007-03-15 22:30:12 UTC


Attachments (Terms of Use)

Description Petter Reinholdtsen 2006-11-29 13:43:11 UTC
When trying to install RHEL 5 Server beta2 in the qemu virtual PC environment,
the installer fail with a python backtrace.  It mention dmidecode parsing as
the problem, and I believe the problem is related to the fact that qemu do
not provide DMI information.  This is the output from dmidecode when running
within qemu:

  # dmidecode 2.8
  # No SMBIOS nor DMI entry point found, sorry.

To test this yourself, install qemu, fetch a RHEL CD image, and
run qemu like this:

  createdisk -s hda 6144
  qemu -cdrom image.iso -hda hda -boot d

The installer stopped when I asked to have a look at the proposed partition
table after asking for the entire hard drive to be erased.

I expected the installer to be able to install RHEL into a qemu machine.

Here is a transcript of the backtrace, manually typed (and probably with some
typos):

Traceback (most recent call first):
  File "/usr/lib/anaconda/iutil.py", line 71, in execWithCapture
    raise RuntimeError, "Error running " + command + ": " + msg
  File "/usr/lib/anaconda/iutil.py", line 368, in isMactel
    ["dmidecode", "-s", "system-manufacturer"])
  File "/usr/lib/anaconda/partitions.py", line 825, in sanityCheckAllRequests
    if rhpl.getArch() in ("i386, "x86_64") and iutil.isMactel():
  File "/usr/lib/anaconda/autopart.py", line 1500, in doAutoPartition
    (errors, warnings) = partitions.sanityCheckAllRequests(diskset)
  File "/usr/lib/anaconda/dispatch.py", line 199, in moveStep
    rc = stepFunc(self.anaconda)
  File "/usr/lib/anaconda/dispatch.py", line 122, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/text.py", line 584 in run
    anaconda.dispatch.gotoNext()
  File "/usr/bin/anaconda", line 1002, in ?
    anaconda.intf.run(anaconda)
RuntimeError: Error running /usr/sbin/dmidecode: Ugyldig format pƄ eksekverbar 
fil

(The last message translates from Norwegian to "Illegal format of executable 
file")

When I try to run the same program in the shell on tty2, I get "cannot execute
binary file".

Comment 1 Alan Cox 2007-01-02 15:08:48 UTC
Looks like an installer problem not a dmidecode one, not sure if someone packed
the wrong bnary or didn't leave something static that should be in that build.


Comment 2 Chris Lumens 2007-03-12 20:43:27 UTC
Is this still a problem in more recent trees?

Comment 3 Petter Reinholdtsen 2007-03-15 16:00:11 UTC
I'm testing a qemu installation of RHEL 5 client for i386 now, and the
installer did not crash during partitioning as before.  I assume it indicate
that the bug is fixed.

Comment 4 David Cantrell 2007-03-15 22:30:12 UTC
Closing as CURRENTRELEASE per comment #3.


Note You need to log in before you can comment on or make changes to this bug.