Bug 2177 - seeq8005 driver misdetection
seeq8005 driver misdetection
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
6.0
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Cristian Gafton
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-04-14 08:00 EDT by Need Real Name
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-06-18 12:42:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 1999-04-14 08:00:51 EDT
Since the seeq8005 driver is not modular, its inclusion in
the kernel causes problems when a sound card is on port
0x320, and possibly other ports.

The driver does not have enough detection logic to determine
that it is not talking to its intended device and tries to
treat the sound card as an ethernet card, thus making the
default kernels unusable.

I don't know if this happens with all sound cards on port
0x320 or just a Gravis Ultrasound Pnp.
Comment 1 Alan Cox 1999-06-12 09:01:59 EDT
I've added modular support to this driver. I don't have an 8005 so if
you can test it when its done then we can make sure the next RH has
it modular

Alan
Comment 2 Cristian Gafton 1999-06-18 12:42:59 EDT
In the meantime, in the shipping kernel the driver was disabled.
Future kernels will include it as a module.

Note You need to log in before you can comment on or make changes to this bug.