Bug 217701 - HVM save and restore fails with obscure error message
HVM save and restore fails with obscure error message
Status: CLOSED DUPLICATE of bug 214995
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: xen (Show other bugs)
5.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Berrange
:
Depends On: 217610
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-29 09:45 EST by Stephen Tweedie
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-14 15:04:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Stephen Tweedie 2006-11-29 09:45:24 EST
fv save/restore is not supported, but xen tries to do it anyway and fails with
an obscure error message.  The tools really need to fail cleanly in this case.

 +++ This bug was initially created as a clone of Bug #217610 +++

Description of problem:

I am unable to save a running guest on a full virt system. My test case has a
guest installed with rhel3u8. Turned SELinux off to eliminate issues and xm save
still fails.

Test system is and AMD tyan i686 - Cpus:4 Memory:1803 MB 

# xm list
Name                                      ID Mem(MiB) VCPUs State   Time(s)
Domain-0                                   0     1803     4 r-----  26086.1
rhel3u8-i386                             164      600     1 -b----     21.0

# xm save rhel3u8-i386 /var/lib/xen/images/save.img
Error: /usr/lib/xen/bin/xc_save 21 164 0 0 0 failed
Usage: xm save <Domain> <CheckpointFile>

Save a domain state to restore later.
# getenforce
Permissive

Version-Release number of selected component (if applicable):
Clean install of RHEL5-Beta2 tree.
Linux amd-tyan-03.lab.boston.redhat.com 2.6.18-1.2747.el5xen #1 SMP Thu Nov 9
19:33:10 EST 2006 i686 athlon i386 GNU/Linux
# rpm -q xen xen-libs
xen-3.0.3-8.el5
xen-libs-3.0.3-8.el5

How reproducible:
always

Steps to Reproduce:
1. install rhel3u8 full virt guest
2. xm create guest
3.
  
Actual results:
unable to save running guest.

Expected results:
guest should be saved ready for restore later

Additional info:
Comment 1 RHEL Product and Program Management 2006-11-29 10:01:11 EST
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 2 Daniel Berrange 2007-06-14 15:04:03 EDT
HVM save & restore is already implemented as a result of bug 214995, so this bug
is no longer relevant.

* Thu Jun 14 2007 Daniel P. Berrange <berrange@redhat.com> - 3.0.3-27.el5
- Back-port 3.1.0  HVM save/restore changes to XenD (rhbz#214995)


*** This bug has been marked as a duplicate of 214995 ***

Note You need to log in before you can comment on or make changes to this bug.