Bug 217720 - "u" inside a sed substution does not work
"u" inside a sed substution does not work
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: sed (Show other bugs)
4.0
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Petr Machata
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-29 11:00 EST by John Curcio
Modified: 2015-05-04 21:32 EDT (History)
1 user (show)

See Also:
Fixed In Version: RHBA-2008-0202
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-09 12:10:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Fix for RHEL-4 (1.31 KB, patch)
2006-12-12 08:42 EST, Petr Machata
no flags Details | Diff
Test case. (407 bytes, application/x-shellscript)
2006-12-12 08:42 EST, Petr Machata
no flags Details

  None (edit)
Description John Curcio 2006-11-29 11:00:10 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.12) Gecko/20050915 Firefox/1.0.7

Description of problem:
Executing => /bin/echo dsyn | /bin/sed -e 's/[a-z]/\u&/g' does not give proper results ... ie, it only results in a blank carriage return instead of having the imput characters translated to upper case

Version-Release number of selected component (if applicable):
sed-4.1.2-4 & sed-4.1.2-5-EL4

How reproducible:
Always


Steps to Reproduce:
1./bin/echo dsyn | /bin/sed -e 's/[a-z]/\u&/g'
2.
3.

Actual Results:
Executing this command gives me no results ... just a blank carrage return.

Expected Results:
I should have the charcaters "dsyn" translated to upper case.

Additional info:
While not a bug that crashes our system, this does effect our production environment rather significantly and is rather time sensitive.
Comment 1 Petr Machata 2006-12-12 08:42:12 EST
Created attachment 143388 [details]
Fix for RHEL-4

This patch is backport from 4.1.3.
Comment 2 Petr Machata 2006-12-12 08:42:54 EST
Created attachment 143389 [details]
Test case.
Comment 9 errata-xmlrpc 2008-04-09 12:10:30 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2008-0202.html

Note You need to log in before you can comment on or make changes to this bug.