Bug 217733 - iptables extensions are not built
iptables extensions are not built
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: iptables (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Thomas Woerner
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-29 12:53 EST by Ben Grimm
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-10 05:19:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ben Grimm 2006-11-29 12:53:10 EST
The package, as it is built, excludes most of the extensions due to the way the
source determines whether to build them.  The Makefile for iptables looks for
KERNEL_DIR (which the rpm sets to /usr) to find the kernel source which is then
used by dozens of test scripts (iptables-1.3.5/extensions/.*-test) to determine
if the kernel has features.   

$ cat .CLUSTERIP-test 
#! /bin/sh
[ -f $KERNEL_DIR/net/ipv4/netfilter/ipt_CLUSTERIP.c ] && echo CLUSTERIP

Without a valid KERNEL_DIR, these 40 or so tests fail and the extensions are not
 available in the package.  The really easy work around is to put a kernel into
/usr/src/linux and set KERNEL_DIR in the spec.   But I suspect it would be
better to patch the tests.
Comment 1 Thomas Woerner 2007-08-29 10:49:41 EDT
Please have a look at iptables-1.3.8-2.fc6 in the testing tree.
Comment 2 Thomas Woerner 2007-09-10 05:19:01 EDT
Fixed in updates in package iptables-1.3.8-2.fc6.

Note You need to log in before you can comment on or make changes to this bug.