Bug 217749 - sendmail startup is slow (3 minutes) when not on a network
sendmail startup is slow (3 minutes) when not on a network
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: sendmail (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Thomas Woerner
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-29 14:03 EST by Orion Poplawski
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-04-10 05:42:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
custom sendmail.mc (2.15 KB, text/plain)
2006-11-29 14:03 EST, Orion Poplawski
no flags Details

  None (edit)
Description Orion Poplawski 2006-11-29 14:03:38 EST
Description of problem:

Booting my laptop off network, it hangs for 3 minutes starting sendmail.  Log shows:

Nov 28 14:02:39 cynosure sendmail[2176]: My unqualified host name (cynosure)
unknown; sleeping for retry
Nov 28 14:03:39 cynosure sendmail[2176]: unable to qualify my own domain name
(cynosure) -- using short name
Nov 28 14:03:40 cynosure sendmail[2176]: alias database /etc/aliases rebuilt by root
Nov 28 14:03:40 cynosure sendmail[2176]: /etc/aliases: 76 aliases, longest 10
bytes, 765 bytes total
Nov 28 14:03:40 cynosure sendmail[2181]: My unqualified host name (cynosure)
unknown; sleeping for retry
Nov 28 14:04:40 cynosure sendmail[2181]: unable to qualify my own domain name
(cynosure)-- using short name
Nov 28 14:04:40 cynosure sendmail[2182]: starting daemon (8.13.8):
SMTP+queueing@01:00:00
Nov 28 14:04:41 cynosure sm-msp-queue[2190]: My unqualified host name (cynosure)
unknown; sleeping for retry
Nov 28 14:05:41 cynosure sm-msp-queue[2190]: unable to qualify my own domain
name (cynosure) -- using short name
Nov 28 14:05:41 cynosure sm-msp-queue[2193]: starting daemon (8.13.8):
queueing@01:00:00

Version-Release number of selected component (if applicable):
sendmail-8.13.8-2

We use a custom sendmail.mc, but this has been fine before (FC1-5).
Comment 1 Orion Poplawski 2006-11-29 14:03:38 EST
Created attachment 142408 [details]
custom sendmail.mc
Comment 2 Robert Scheck 2007-04-07 05:08:41 EDT
And what is the golden option which makes sendmail faster when no network is 
available?
Comment 3 Thomas Woerner 2007-04-10 05:42:22 EDT
Sendmail is trying to resolve the domain cora.nwra.com, because you configured
it to use it for masquerading. You have to make sure that this domain is
resolvable even if the network is unreachable. I'd suggest to add an entry to
/etc/hosts.

Note You need to log in before you can comment on or make changes to this bug.