Bug 217816 - Package updater crashed with a mensage/log saved and reproduced here in "description"
Package updater crashed with a mensage/log saved and reproduced here in "desc...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: pirut (Show other bugs)
6
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Fedora Extras Quality Assurance
file:///home/faustino/updater_crash.jpg
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-29 21:52 EST by Need Real Name
Modified: 2008-01-28 22:42 EST (History)
2 users (show)

See Also:
Fixed In Version: updates
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-28 22:42:15 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2006-11-29 21:52:33 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; pt-BR; rv:1.8.0.8) Gecko/20061107 Fedora/1.5.0.8-1.fc6 Firefox/1.5.0.8

Description of problem:
Detailed Bug Reported and saved:

Component: Software Updater
Summary: TBe634e670 __init__.py:767:downloadHeader:RepoError: failure: system-config-soundcard-2.0.5-2.fc6.noarch.rpm from updates: [Errno 256] No more mirrors to try.

Traceback (most recent call last):
  File "/usr/sbin/pup", line 433, in _apply
    self.applyChanges(self.mainwin)
  File "/usr/lib/python2.4/site-packages/pirut/__init__.py", line 559, in applyChanges
    self.checkDeps(mainwin)
  File "/usr/lib/python2.4/site-packages/pirut/__init__.py", line 324, in checkDeps
    self.populateTs(keepold=0)
  File "/usr/lib/python2.4/site-packages/yum/depsolve.py", line 153, in populateTs
    self.downloadHeader(txmbr.po)
  File "/usr/lib/python2.4/site-packages/yum/__init__.py", line 767, in downloadHeader
    raise Errors.RepoError, saved_repo_error
RepoError: failure: system-config-soundcard-2.0.5-2.fc6.noarch.rpm from updates: [Errno 256] No more mirrors to try.

Local variables in innermost frame:
errors: {}
e: [Errno 2] Arquivo ou diretório não encontrado: '//var/cache/yum/updates/headers/system-config-soundcard-2.0.5-2.fc6.noarch.hdr'
self: <__main__.PackageUpdater object at 0x8bd090c>
saved_repo_error: failure: system-config-soundcard-2.0.5-2.fc6.noarch.rpm from updates: [Errno 256] No more mirrors to try.
repo: updates
checkfunc: (<bound method PackageUpdater.verifyHeader of <__main__.PackageUpdater object at 0x8bd090c>>, (<yum.sqlitesack.YumAvailablePackageSqlite instance at 0x97c694c>, 1), {})
local: //var/cache/yum/updates/headers/system-config-soundcard-2.0.5-2.fc6.noarch.hdr
po: system-config-soundcard - 2.0.5-2.fc6.noarch

Version-Release number of selected component (if applicable):


How reproducible:
Always


Steps to Reproduce:
1.In kde interface (I dont know if hapens in gnome desktop),clicking in System>Software updater>login as root>accept the apointed arquives ...and crasch
2.
3.

Actual Results:
Here a print screen of what happens:
file:///home/faustino/updater_crash.jpg

Expected Results:
the crash ocurred when trying the last software update (today). In the others times the update ocurred normaly  

Additional info:
computer: AMD Atlhon 64 - 3200 MHz, 1024Mb/RAM, Fedora Core 6 - ZOD - DVD i386
Comment 1 Red Hat Bugzilla 2007-04-11 21:49:51 EDT
User bnackash@redhat.com's account has been closed
Comment 2 Peter van Egdom 2008-01-26 08:31:09 EST
Thank you for the report. However this has been reported to the incorrect
component. Reassigning from "up2date" to "pirut". Feel free to report any
further bugs you find to our bug tracking system.
Comment 3 Jeremy Katz 2008-01-28 22:42:15 EST
This should be resolved in current updates of the pirut package

Note You need to log in before you can comment on or make changes to this bug.