Bug 217819 - Update to cairo-1.3.4 worsen font rendering
Update to cairo-1.3.4 worsen font rendering
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: cairo (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Behdad Esfahbod
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-29 22:58 EST by Deji Akingunola
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-12-20 15:23:15 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Screenshot showing garbled text (267.82 KB, image/png)
2006-11-29 22:58 EST, Deji Akingunola
no flags Details
font config (16.71 KB, application/octet-stream)
2006-11-29 23:00 EST, Deji Akingunola
no flags Details
Implement _cairo_lround with floor(d+0.5) (1.83 KB, patch)
2006-12-01 20:40 EST, Carl Worth
no flags Details | Diff

  None (edit)
Description Deji Akingunola 2006-11-29 22:58:20 EST
Description of problem: Since updating to cairo-1.3.4 rawhide, font rendering
has somehow worsened on my computer. Some texts become garbled (as seen in the
attached screenshot), and short spaces are put between words (strings), e.g.
'mass.streamfunction' been rendered as 'm ass s.str eamfunction'. Moving the
cursor over the texts tends to smoothing it up, in case its garbled, and/or
're-group' the letters in situations where spaces show up in between words.
This rendering issue doesn't seem to be present in the default font setup (i.e.
/etc/fonts/fonts.conf), I have a local.conf (attached) in /etc/fonts (copied
from FC5 fonts.conf) that seems to be causing the issue.
It is perfectly reproducable, downgrading to cairo-1.3.2 does fix it for me.


Version-Release number of selected component (if applicable): cairo-1.3.4


How reproducible: Always


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Deji Akingunola 2006-11-29 22:58:21 EST
Created attachment 142462 [details]
Screenshot showing garbled text
Comment 2 Deji Akingunola 2006-11-29 23:00:51 EST
Created attachment 142463 [details]
font config
Comment 3 Carl Worth 2006-12-01 20:02:07 EST
Thanks for the report.

I've sucessfully reproduced this issue on my own system.

We're quite confident that this is due to a slightly modified rounding mode
which was implemented in cairo 1.3.4. The problem could be worked around in
nautilus, but we'll really need to fix this in cairo itself.

We're now talking on the cairo list about which approach to use to solve it.

I'll try to remember to post some patches here as well.

-Carl
Comment 4 Carl Worth 2006-12-01 20:40:29 EST
Created attachment 142645 [details]
Implement _cairo_lround with floor(d+0.5)

This patch should fix the bug. It's a performance regression, but likely only
one that will be very noticeable on an embedded system without a hardware
floating-point unit.

We'll have this, (or another faster fix), in the 1.3.6 snapshot which is
planned for next week.

-Carl
Comment 5 Deji Akingunola 2006-12-01 21:09:40 EST
Thanks, I can confirm the patch does indeed fix the bug. And BTW, the whole DE
on my system (a PIII) feels snappier with this new version (1.3.4, even with
this fix). 
Comment 6 Behdad Esfahbod 2006-12-03 02:04:38 EST
Deji, can you confirm that you have font hinting turned off?
Comment 7 Deji Akingunola 2006-12-03 08:39:00 EST
(In reply to comment #6)
> Deji, can you confirm that you have font hinting turned off?
On the system where I took the screenshot, yes. But I see the same effect (of
spaces inserted between words) on another computer with hinting turned on (i.e,
slight hinting in the gnome font-preference).
Comment 8 Behdad Esfahbod 2006-12-04 12:37:45 EST
Yeah, I seem to reproduce it for None and Slight hinting settings.
Comment 9 Behdad Esfahbod 2006-12-20 15:23:15 EST
Fixed in cairo-1.3.6

Note You need to log in before you can comment on or make changes to this bug.