Bug 21784 - openssh 2.3.0p1 connection error
openssh 2.3.0p1 connection error
Status: CLOSED DUPLICATE of bug 21509
Product: Red Hat Linux
Classification: Retired
Component: openssh (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Nalin Dahyabhai
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-12-05 18:17 EST by jeff_grady
Modified: 2008-05-01 11:37 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-12-05 19:39:18 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description jeff_grady 2000-12-05 18:17:25 EST
I recently upgraded to openssh-2.3.0p1 via the updated rpm, and I noticed
that I couldn't connect to my university server anymore:

my computer:
[jgrady@blarg jgrady]$ ssh -V
SSH Version OpenSSH_2.3.0p1, protocol versions 1.5/2.0.
Compiled with SSL (0x0090581f).

university server:
bash$ ssh -V
ssh: SSH Secure Shell 2.3.0 (non-commercial version) on mips-sgi-irix6.5

and the verbose output of my connection attempt:

[jgrady@blarg jgrady]$ ssh -v xxxxxx.xxx.xxx.xxx
SSH Version OpenSSH_2.3.0p1, protocol versions 1.5/2.0.
Compiled with SSL (0x0090581f).
debug: Reading configuration data /etc/ssh/ssh_config
debug: Applying options for *
debug: Seeding random number generator
debug: ssh_connect: getuid 500 geteuid 0 anon 0
debug: Connecting to xxxxxx.xxx.xxx.xxx [xxx.xxx.xxx.xxx] port 22.
debug: Allocated local port 1021.
debug: Connection established.
debug: Remote protocol version 1.99, remote software version 2.1.0.pl2 SSH
Secure Shell (non-commercial)
debug: match: 2.1.0.pl2 SSH Secure Shell (non-commercial) pat ^2\.

Enabling compatibility mode for protocol 2.0
debug: Local version string SSH-2.0-OpenSSH_2.3.0p1
debug: Seeding random number generator
debug: send KEXINIT
debug: done
debug: wait KEXINIT
debug: got kexinit: diffie-hellman-group1-sha1
debug: got kexinit: ssh-dss
debug: got kexinit: 3des-cbc,blowfish-cbc,twofish-cbc,arcfour,none
debug: got kexinit: 3des-cbc,blowfish-cbc,twofish-cbc,arcfour,none
debug: got kexinit: hmac-md5,md5-8,none
debug: got kexinit: hmac-md5,md5-8,none
debug: got kexinit: none,zlib
debug: got kexinit: none,zlib
debug: got kexinit: 
debug: got kexinit: 
debug: first kex follow: 0 
debug: reserved: 0 
debug: done
debug: kex: server->client 3des-cbc hmac-md5 none
debug: kex: client->server 3des-cbc hmac-md5 none
debug: Sending SSH2_MSG_KEXDH_INIT.
debug: bits set: 518/1024
debug: Wait SSH2_MSG_KEXDH_REPLY.
debug: Got SSH2_MSG_KEXDH_REPLY.
debug: Host 'xxxxxx.xxx.xxx.xxx' is known and matches the DSA host key.
debug: bits set: 503/1024
autodetect SSH_BUG_SIGBLOB
debug: len 40 datafellows -2
Received packet with bad string length 419867393
debug: Calling cleanup 0x805f3c0(0x0)

...and there it dies.

I mailed the openssh developer list, and I was informed that this problem
has already been addressed and that I could get a fixed snapshot version at
http://www.mindrot.org/misc/openssh/ 

So I downloaded openssh-SNAP-20001206.tar.gz, installed it, and the problem
went magically away.

Just thought you should know the updated openssh rpm was broken.  :/
Comment 1 Pekka Savola 2000-12-06 02:43:40 EST

*** This bug has been marked as a duplicate of 21509 ***

Note You need to log in before you can comment on or make changes to this bug.